diff mbox series

[bug#58387,v2,1/2] gnu: Add python-pylatexenc. * gnu/packages/python-xyz.scm (python-pylatexenc): New variable.

Message ID 20221009110401.29845-1-matf@disr.it
State Accepted
Headers show
Series [bug#58387,v2,1/2] gnu: Add python-pylatexenc. * gnu/packages/python-xyz.scm (python-pylatexenc): New variable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Oct. 9, 2022, 11:04 a.m. UTC
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

\( Oct. 9, 2022, 11:11 a.m. UTC | #1
On Sun Oct 9, 2022 at 12:04 PM BST, M wrote:
> +    (synopsis
> +     "LaTeX parser for unicode/latex conversion")

Synopsis strings generally go on the same line as the field ID.

> +    (description
> +     "python-pylatexenc is a LaTeX parser providing latex-to-unicode and
> +unicode-to-latex conversion.")

s/python-pylatexenc/@code{pylatexenc}/

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 054bd3ed29..15540ffae3 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1617,6 +1617,26 @@  (define-public python-hnswlib
 approximate nearest neighbor search with Python bindings.")
     (license license:asl2.0)))
 
+(define-public python-pylatexenc
+  (package
+    (name "python-pylatexenc")
+    (version "2.10")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pylatexenc" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1ls09z47b5md71gkxcj7fd87ynpvv2walgp2w6z31p26xf2gvn1x"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/phfaist/pylatexenc")
+    (synopsis
+     "LaTeX parser for unicode/latex conversion")
+    (description
+     "python-pylatexenc is a LaTeX parser providing latex-to-unicode and
+unicode-to-latex conversion.")
+    (license license:expat)))
+
 (define-public python-pyls-black
   (package
     (name "python-pyls-black")