diff mbox series

[bug#58244,v2,1/2] gnu: Add perl-file-fcntllock.

Message ID 20221009050824.130410-2-bauermann@kolabnow.com
State Accepted
Headers show
Series Update public-inbox | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Oct. 9, 2022, 5:08 a.m. UTC
* gnu/packages/perl.scm (perl-file-fcntllock): New variable.
---
 gnu/packages/perl.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 64868607dc95..5f3666fe3b6c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11641,6 +11641,28 @@  (define-public perl-file-finder
 used as the head of many different sequences.")
     (license license:perl-license)))
 
+(define-public perl-file-fcntllock
+  (package
+    (name "perl-file-fcntllock")
+    (version "0.22")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/J/JT/JTT/File-FcntlLock-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "1pxwknq4lw0wqpkh8pf18qsjf9g503vx6a5184vvffprzwpbp6ls"))))
+    (build-system perl-build-system)
+    (home-page "https://metacpan.org/release/File-FcntlLock")
+    (synopsis "File locking with fcntl(2)")
+    (description "File locking in Perl is usually done using the @code{flock}
+function.  Unfortunately, this only allows locks on whole files and is often
+implemented in terms of the @code{flock(2)} system function which has some
+shortcomings (especially concerning locks on remotely mounted file systems)
+and slightly different behaviour than @code{fcntl(2)}.")
+    (license license:perl-license)))
+
 (define-public perl-font-ttf
   (package
     (name "perl-font-ttf")