diff mbox series

[bug#58386,2/2] gnu: Add passage.

Message ID 20221008224453.8634-2-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#58386,1/2] gnu: passage: Rename package to passage-game. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Oct. 8, 2022, 10:44 p.m. UTC
* gnu/packages/password-utils.scm (passage): New variable.
---
 gnu/packages/password-utils.scm | 39 +++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Tobias Geerinckx-Rice Oct. 8, 2022, 11:05 p.m. UTC | #1
Heyo,

Nicolas Graves via Guix-patches via 写道:
> +(define-public passage

Thanks!

Most points below can be fixed up by a committer, including the 
description, but those tend to sound better when written by an 
actual user.  If you'd like to give it a try.

> +    (build-system copy-build-system)
> +    (propagated-inputs
> +     (list util-linux git qrencode sed tree age))

Super-nitpick: inputs conventionally hang out a bit lower, under 
the arguments field.

> +    (build-system copy-build-system)

Duped.

> +    (arguments
> +     '(#:phases (modify-phases %standard-phases
> +                  (add-after 'unpack 'rename-exe

s/exe/script/ (or sure, executable).

> +                    (lambda _
> +                      (rename-file "src/password-store.sh"
> +                                   "src/passage"))))
> +       #:install-plan
> +       (list '("src/passage" "/bin/")
> +             '("src/completion/pass.bash-completion"
> +               "/share/bash-completion/completions/")

OK, I've been looking at this for an embarrasingly long time 
trying to figure out what you're trying to communicate with '(… 
(list '(…))).  It seems very deliberate.  Any hints?  :-p

> +    (home-page "https://github.com/FiloSottile/passage")
> +    (synopsis "A fork of the password-store encrypted password 
> manager")

Another nitpic^Wcool tip: @command{} & friends work here just as 
well as in the description.  There's no difference.

The text should describe the package, not its ancestry.

> +    (description "This package provides a fork of the 
> @code{password-store}
> +encrypted password manager.  It relies on @code{age} instead of
> +@code{gnupg}.")

Same here.  I know all of these words but what do they mean?

> +    (license license:gpl2+)))

Checked.

> +
>  (define-public pass-otp
>    (package
>      (name "pass-otp")

> I've made the choice to rename the existing passage game to
> passage-game in a first commit, I hope it's OK. 

No, I don't think it is.  Adding this script need not affect other 
packages.

Kind regards,

T G-R
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 8e29bef484..6bc3b99af4 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -37,6 +37,7 @@ 
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
 ;;; Copyright © 2022 ( <paren@disroot.org>
+;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -57,6 +58,7 @@  (define-module (gnu packages password-utils)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix utils)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system go)
   #:use-module (guix build-system python)
@@ -589,6 +591,43 @@  (define-public password-store
 through the pass command.")
     (license license:gpl2+)))
 
+(define-public passage
+  (package
+    (inherit password-store)
+    (name "passage")
+    (version "1.7.4a0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/FiloSottile/passage")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "17899whffnpqqx9x1nx2b8bfxbxlh1pwlglqa0kznl0cn6sb37ql"))))
+    (build-system copy-build-system)
+    (propagated-inputs
+     (list util-linux git qrencode sed tree age))
+    (build-system copy-build-system)
+    (arguments
+     '(#:phases (modify-phases %standard-phases
+                  (add-after 'unpack 'rename-exe
+                    (lambda _
+                      (rename-file "src/password-store.sh"
+                                   "src/passage"))))
+       #:install-plan
+       (list '("src/passage" "/bin/")
+             '("src/completion/pass.bash-completion"
+               "/share/bash-completion/completions/")
+             '("src/completion/pass.zsh-completion"
+               "/share/zsh/site-functions/"))))
+    (home-page "https://github.com/FiloSottile/passage")
+    (synopsis "A fork of the password-store encrypted password manager")
+    (description "This package provides a fork of the @code{password-store}
+encrypted password manager.  It relies on @code{age} instead of
+@code{gnupg}.")
+    (license license:gpl2+)))
+
 (define-public pass-otp
   (package
     (name "pass-otp")