diff mbox series

[bug#58369] gnu: Add python-simple-pid.

Message ID 20221007215911.9083-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#58369] gnu: Add python-simple-pid. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 7, 2022, 9:59 p.m. UTC
* gnu/packages/python-science.scm (python-simple-pid): New variable.
---
 gnu/packages/python-science.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index f2cbfb0043..293ad156f6 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;; Copyright © 2022 Wiktor Żelazny <wzelazny@vurv.cz>
 ;;; Copyright © 2022 Eric Bavier <bavier@posteo.net>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1482,6 +1483,29 @@  (define-public python-deepdish
 interoperability offered by HDF5.")
     (license license:bsd-3)))
 
+(define-public python-simple-pid
+  (package
+    (name "python-simple-pid")
+    (version "1.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "simple-pid" version))
+              (sha256
+               (base32
+                "094mz6rmfq1h0gpns5vlxb7xf9297hlkhndw7g9k95ziqfkv7mk0"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "unittest" "discover" "tests/")))))))
+    (home-page "https://github.com/m-lundberg/simple-pid")
+    (synopsis "Easy to use PID controller")
+    (description "This package provides a simple, easy to use PID controller.")
+    (license license:expat)))
+
 (define-public python-opt-einsum
   (package
     (name "python-opt-einsum")