diff mbox series

[bug#58261,v2,04/13] gnu: Add tinydir.

Message ID 20221007152148.32591-5-david.elsing@posteo.net
State Accepted
Headers show
Series None | expand

Commit Message

David Elsing Oct. 7, 2022, 3:21 p.m. UTC
* gnu/packages/cpp.scm (tinydir): New variable.
---
 gnu/packages/cpp.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Liliana Marie Prikler Oct. 9, 2022, 11:48 a.m. UTC | #1
Am Freitag, dem 07.10.2022 um 15:21 +0000 schrieb David Elsing:
> * gnu/packages/cpp.scm (tinydir): New variable.
> ---
>  gnu/packages/cpp.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
> 
> diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
> index dca0245df5..e99fdcecd8 100644
> --- a/gnu/packages/cpp.scm
> +++ b/gnu/packages/cpp.scm
> @@ -2065,3 +2065,30 @@ (define-public sajson
>        (description "@code{sajson} is an in-place JSON parser with
> support for
>  parsing with only a single memory allocation.")
>        (license license:expat))))
> +
> +(define-public tinydir
> +  (package
> +    (name "tinydir")
> +    (version "1.2.5")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/cxong/tinydir")
> +                    (commit version)))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "1nprgdfx4i8wzc1idw6chan4fjfa75b5ll8kghdc0q2278pny259"))
> +              (modules '((guix build utils)))
> +              (snippet '(delete-file-recursively "tests/cbehave"))))
> +    (build-system copy-build-system)
> +    (arguments
> +     (list
> +      ;; TODO: Tests contain a private fork of cbehave and a bundled
> copy of rlutil
> +      #:install-plan
> +      #~'(("tinydir.h" "include/"))))
> +    (home-page "https://github.com/cxong/tinydir")
> +    (synopsis "C header-only directory and file reader")
Just "Directory and file reader", though I'm not too sure whether it
actually reads files.
> +    (description "@code{tinydir} is a header-only C library to
> portably read
> +files and directories.")
Since in this case "portable" means "works on the Microsoft OS and
Unix", I'm pretty sure it's but a buzzword.
> +    (license license:bsd-2)))
diff mbox series

Patch

diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index dca0245df5..e99fdcecd8 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -2065,3 +2065,30 @@  (define-public sajson
       (description "@code{sajson} is an in-place JSON parser with support for
 parsing with only a single memory allocation.")
       (license license:expat))))
+
+(define-public tinydir
+  (package
+    (name "tinydir")
+    (version "1.2.5")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/cxong/tinydir")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1nprgdfx4i8wzc1idw6chan4fjfa75b5ll8kghdc0q2278pny259"))
+              (modules '((guix build utils)))
+              (snippet '(delete-file-recursively "tests/cbehave"))))
+    (build-system copy-build-system)
+    (arguments
+     (list
+      ;; TODO: Tests contain a private fork of cbehave and a bundled copy of rlutil
+      #:install-plan
+      #~'(("tinydir.h" "include/"))))
+    (home-page "https://github.com/cxong/tinydir")
+    (synopsis "C header-only directory and file reader")
+    (description "@code{tinydir} is a header-only C library to portably read
+files and directories.")
+    (license license:bsd-2)))