diff mbox series

[bug#58261,v2,09/13] gnu: Add coordgenlibs.

Message ID 20221007152148.32591-10-david.elsing@posteo.net
State Accepted
Headers show
Series None | expand

Commit Message

David Elsing Oct. 7, 2022, 3:21 p.m. UTC
* gnu/packages/chemistry.scm (coordgenlibs): New variable.
---
 gnu/packages/chemistry.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

Liliana Marie Prikler Oct. 9, 2022, 11:56 a.m. UTC | #1
Am Freitag, dem 07.10.2022 um 15:21 +0000 schrieb David Elsing:
> * gnu/packages/chemistry.scm (coordgenlibs): New variable.
> ---
>  gnu/packages/chemistry.scm | 27 +++++++++++++++++++++++++++
>  1 file changed, 27 insertions(+)
> 
> diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
> index 6eb1e4a694..1510cbab41 100644
> --- a/gnu/packages/chemistry.scm
> +++ b/gnu/packages/chemistry.scm
> @@ -791,3 +791,30 @@ (define-public maeparser
>      (synopsis "Maestro file parser")
>      (description "maeparser is a parser for Schrodinger Maestro
> files.")
>      (license license:expat)))
> +
> +(define-public coordgenlibs
> +  (package
> +    (name "coordgenlibs")
> +    (version "3.0.1")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url
> "https://github.com/schrodinger/coordgenlibs/")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "0d09x3v38i9y184bml020bq7xizdrdwng38qmdxlplzfhqkjdidv"))))
> +    (build-system cmake-build-system)
> +    (native-inputs (list boost))
> +    (inputs (list maeparser))
> +    (arguments
> +     (list
> +      #:configure-flags
> +      #~(list "-DCOORDGEN_RIGOROUS_BUILD=OFF"
> +              "-DCOORDGEN_USE_MAEPARSER=ON")))
> +    (home-page "https://github.com/schrodinger/coordgenlibs/")
> +    (synopsis "2D coordinate generation")
> +    (description "@code{coordgenlibs} contains algorithms to
> generate 2D
> +coordinates.  It has an emphasis on quality rather than speed.")
It emphasises quality over speed.  That being said, is it that hard to
generate points?  What's the full context here?
> +    (license license:bsd-3)))
David Elsing Oct. 13, 2022, 9 p.m. UTC | #2
Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

> Am Freitag, dem 07.10.2022 um 15:21 +0000 schrieb David Elsing:
>> * gnu/packages/chemistry.scm (coordgenlibs): New variable.
>> ---
>>  gnu/packages/chemistry.scm | 27 +++++++++++++++++++++++++++
>>  1 file changed, 27 insertions(+)
>> 
>> diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
>> index 6eb1e4a694..1510cbab41 100644
>> --- a/gnu/packages/chemistry.scm
>> +++ b/gnu/packages/chemistry.scm
>> @@ -791,3 +791,30 @@ (define-public maeparser
>>      (synopsis "Maestro file parser")
>>      (description "maeparser is a parser for Schrodinger Maestro
>> files.")
>>      (license license:expat)))
>> +
>> +(define-public coordgenlibs
>> +  (package
>> +    (name "coordgenlibs")
>> +    (version "3.0.1")
>> +    (source (origin
>> +              (method git-fetch)
>> +              (uri (git-reference
>> +                    (url
>> "https://github.com/schrodinger/coordgenlibs/")
>> +                    (commit (string-append "v" version))))
>> +              (file-name (git-file-name name version))
>> +              (sha256
>> +               (base32
>> +               
>> "0d09x3v38i9y184bml020bq7xizdrdwng38qmdxlplzfhqkjdidv"))))
>> +    (build-system cmake-build-system)
>> +    (native-inputs (list boost))
>> +    (inputs (list maeparser))
>> +    (arguments
>> +     (list
>> +      #:configure-flags
>> +      #~(list "-DCOORDGEN_RIGOROUS_BUILD=OFF"
>> +              "-DCOORDGEN_USE_MAEPARSER=ON")))
>> +    (home-page "https://github.com/schrodinger/coordgenlibs/")
>> +    (synopsis "2D coordinate generation")
>> +    (description "@code{coordgenlibs} contains algorithms to
>> generate 2D
>> +coordinates.  It has an emphasis on quality rather than speed.")
> It emphasises quality over speed.  That being said, is it that hard to
> generate points?  What's the full context here?
Ah, it's 2D coordinates for molecules. :)
>> +    (license license:bsd-3)))
diff mbox series

Patch

diff --git a/gnu/packages/chemistry.scm b/gnu/packages/chemistry.scm
index 6eb1e4a694..1510cbab41 100644
--- a/gnu/packages/chemistry.scm
+++ b/gnu/packages/chemistry.scm
@@ -791,3 +791,30 @@  (define-public maeparser
     (synopsis "Maestro file parser")
     (description "maeparser is a parser for Schrodinger Maestro files.")
     (license license:expat)))
+
+(define-public coordgenlibs
+  (package
+    (name "coordgenlibs")
+    (version "3.0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/schrodinger/coordgenlibs/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d09x3v38i9y184bml020bq7xizdrdwng38qmdxlplzfhqkjdidv"))))
+    (build-system cmake-build-system)
+    (native-inputs (list boost))
+    (inputs (list maeparser))
+    (arguments
+     (list
+      #:configure-flags
+      #~(list "-DCOORDGEN_RIGOROUS_BUILD=OFF"
+              "-DCOORDGEN_USE_MAEPARSER=ON")))
+    (home-page "https://github.com/schrodinger/coordgenlibs/")
+    (synopsis "2D coordinate generation")
+    (description "@code{coordgenlibs} contains algorithms to generate 2D
+coordinates.  It has an emphasis on quality rather than speed.")
+    (license license:bsd-3)))