diff mbox series

[bug#58313] gnu: gtkwave: Update to 3.3.113.

Message ID 20221005191105.22227-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#58313] gnu: gtkwave: Update to 3.3.113. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 5, 2022, 7:11 p.m. UTC
* gnu/packages/fpga.scm (gtkwave): Update to 3.3.113.
[inputs]: Use new style.
[arguments]: Use gexp.
---
 gnu/packages/fpga.scm | 27 ++++++++++++++-------------
 1 file changed, 14 insertions(+), 13 deletions(-)

Comments

Ludovic Courtès Oct. 11, 2022, 1:21 p.m. UTC | #1
Hi,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/fpga.scm (gtkwave): Update to 3.3.113.
> [inputs]: Use new style.
> [arguments]: Use gexp.

Applied, thanks!

Ludo’.
jgart Oct. 11, 2022, 5:47 p.m. UTC | #2
On Tue, 11 Oct 2022 15:21:55 +0200 Ludovic Courtès <ludo@gnu.org> wrote:

Thank you!

--
jgart
diff mbox series

Patch

diff --git a/gnu/packages/fpga.scm b/gnu/packages/fpga.scm
index 11c56477a8..33c7afda00 100644
--- a/gnu/packages/fpga.scm
+++ b/gnu/packages/fpga.scm
@@ -6,6 +6,7 @@ 
 ;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
 ;;; Copyright © 2021 Andrew Miloradovsky <andrew@interpretmath.pw>
 ;;; Copyright © 2022 Christian Gelinek <cgelinek@radlogic.com.au>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -24,6 +25,7 @@ 
 
 (define-module (gnu packages fpga)
   #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix gexp)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -352,7 +354,7 @@  (define-public arachne-pnr
 (define-public gtkwave
   (package
     (name "gtkwave")
-    (version "3.3.111")
+    (version "3.3.113")
     (source
      (origin
        (method url-fetch)
@@ -362,23 +364,22 @@  (define-public gtkwave
                   (string-append "http://gtkwave.sourceforge.net/"
                                  "gtkwave-" version ".tar.gz")))
        (sha256
-        (base32 "15n2gv2hd7h23cci95ij7yr71fkxppb209sfdsmmngh3fik09rpn"))))
+        (base32 "1zqkfchmns5x90qxa8kg39bfhax3vxf1mrdz3lhyb9fz1gp4difn"))))
     (build-system gnu-build-system)
     (native-inputs
      (list gperf pkg-config))
     (inputs
-     `(("tcl" ,tcl)
-       ("tk" ,tk)
-       ("gtk+-2" ,gtk+-2)))
+      (list tcl tk gtk+-2))
     (arguments
-     `(#:configure-flags
-       (list (string-append "--with-tcl="
-                            (assoc-ref %build-inputs "tcl")
-                            "/lib")
-             (string-append "--with-tk="
-                            (assoc-ref %build-inputs "tk")
-                            "/lib"))))
-
+      (list 
+        #:configure-flags
+        #~(list 
+            (string-append "--with-tcl="
+                           (assoc-ref %build-inputs "tcl")
+                           "/lib")
+            (string-append "--with-tk="
+                           (assoc-ref %build-inputs "tk")
+                           "/lib"))))
     (synopsis "Waveform viewer for FPGA simulator trace files")
     (description "This package is a waveform viewer for FPGA
 simulator trace files (@dfn{FST}).")