diff mbox series

[bug#58306] gnu: tessen: Update to 2.1.2.

Message ID 20221005123957.1855-1-tanguy@bioneland.org
State Accepted
Headers show
Series [bug#58306] gnu: tessen: Update to 2.1.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Oct. 5, 2022, 12:39 p.m. UTC
* gnu/packages/password-utils.scm (tessen): Update to 2.1.2.
[arguments]: Substitute notify-send, wl-copy and xdg-open.
[inputs] Add libnotify, wl-clipboard and xdg-utils.
---
 gnu/packages/password-utils.scm | 13 +++++++++----
 1 file changed, 9 insertions(+), 4 deletions(-)

Comments

Efraim Flashner Oct. 6, 2022, 5:15 p.m. UTC | #1
Thanks. Patch pushed.
Tanguy LE CARROUR Oct. 7, 2022, 6:18 a.m. UTC | #2
Quoting Efraim Flashner (2022-10-06 19:15:21)
> Thanks. Patch pushed.

Thanks!
diff mbox series

Patch

diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 003e346305..6c20e195ba 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -80,6 +80,7 @@  (define-module (gnu packages password-utils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages golang)
   #:use-module (gnu packages gtk)
@@ -757,7 +758,7 @@  (define-public rofi-pass
 (define-public tessen
   (package
     (name "tessen")
-    (version "2.1.0")
+    (version "2.1.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -766,7 +767,7 @@  (define-public tessen
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1ddsjhzp1qy3jfhxlrzcxgp0gza234yc0sdlngwa3xdj0wr40zs0"))))
+                "01jaxakq847k3v2wid8fzhcmq8mraxz0q1j87s1jv75l1gy4qiij"))))
     (build-system gnu-build-system)
     (arguments
      (list #:tests?
@@ -776,13 +777,17 @@  (define-public tessen
                (add-after 'unpack 'patch-wtype-path
                  (lambda* (#:key inputs #:allow-other-keys)
                    (substitute* "tessen"
-                     (("wtype") (search-input-file inputs "/bin/wtype")))))
+                     (("notify-send") (search-input-file inputs
+                                                         "/bin/notify-send"))
+                     (("wl-copy") (search-input-file inputs "/bin/wl-copy"))
+                     (("wtype") (search-input-file inputs "/bin/wtype"))
+                     (("xdg-open") (search-input-file inputs "/bin/xdg-open")))))
                (delete 'configure)) ;no configure script
            #:make-flags
            #~(list (string-append "PREFIX="
                                   #$output))))
     (native-inputs (list scdoc))
-    (inputs (list wtype))
+    (inputs (list libnotify wl-clipboard wtype xdg-utils))
     (home-page "https://github.com/ayushnix/tessen")
     (synopsis "Frontend for password-store and gopass")
     (description "Tessen is a bash script that can autotype and copy data