diff mbox series

[bug#58257,v2] gnu: Add go-webring.

Message ID 20221004220045.23544-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#58257,v2] gnu: Add go-webring. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 4, 2022, 10 p.m. UTC
* gnu/packages/web.scm (go-webring): New variable.

Hi paren,

Thanks for the review. I changed everything but the blog stuff because
go-webring is not necessarily used in the context of a blog. A webring
can stand on it's own without being associated with a blog. A webring
can associate websites that are not blogs or Guix channels ;()

Here's v2

all best,

jgart
---
 gnu/packages/web.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Ludovic Courtès Oct. 9, 2022, 8:25 p.m. UTC | #1
Hi,

jgart <jgart@dismail.de> skribis:

> * gnu/packages/web.scm (go-webring): New variable.

Applied, thanks!

Ludo’.
jgart Oct. 9, 2022, 8:29 p.m. UTC | #2
On Sun, 09 Oct 2022 22:25:03 +0200 Ludovic Courtès <ludo@gnu.org> wrote:
> Applied, thanks!

THNX! <3
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 3262dbbb10..967d4328b5 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -58,6 +58,7 @@ 
 ;;; Copyright © 2022 cage <cage-dev@twistfold.it>
 ;;; Copyright © 2022 Pradana Aumars <paumars@courrier.dev>
 ;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -8184,6 +8185,33 @@  (define-public quark
       ;; to account for "vendor names".
       (properties '((lint-hidden-cve . ("CVE-2019-15520")))))))
 
+(define-public go-webring
+  (let ((commit "6786a27b0c57df75323217453369c83a4d9f4dea")
+        (revision "0"))
+    (package
+      (name "go-webring")
+      (version (git-version "20220426" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://git.sr.ht/~amolith/go-webring")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "1xra0mapdmda8n0z6zsgcqppdzvxc47p0fahsdyig5qmpk89ar8l"))))
+      (build-system go-build-system)
+      (arguments
+       (list #:import-path "git.sr.ht/~amolith/go-webring"
+             #:install-source? #f))
+      (inputs (list go-github-com-spf13-pflag))
+      (home-page "https://git.sr.ht/~amolith/go-webring")
+      (synopsis "Simple webring implementation")
+      (description
+"@code{go--webring} provides a simple webring implementation as used by
+the Fediring.")
+      (license (list license:cc0 license:bsd-2)))))
+
 (define-public archivebox
   (package
     (name "archivebox")