diff mbox series

[bug#57963,v5,1/2] home: services: Add base.

Message ID 20221002131232.9063-1-higashi@taiju.info
State New
Headers show
Series [bug#57963,v5,1/2] home: services: Add base. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Taiju HIGASHI Oct. 2, 2022, 1:12 p.m. UTC
* gnu/home/services/base.scm: New file.
* gnu/home.scm (): Move home-fontconfig-service-type from
home-environment-default-essential-services to its %home-base-services.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/home.scm               |  5 ++---
 gnu/home/services/base.scm | 35 +++++++++++++++++++++++++++++++++++
 gnu/local.mk               |  2 ++
 3 files changed, 39 insertions(+), 3 deletions(-)
 create mode 100644 gnu/home/services/base.scm

Comments

Taiju HIGASHI Oct. 2, 2022, 1:20 p.m. UTC | #1
Hi,

I'm sorry.   This email is incorrect; the second email, "[PATCH v5 1/2]
home: services: Add base." is correct.

Taiju HIGASHI <higashi@taiju.info> writes:

> * gnu/home/services/base.scm: New file.
> * gnu/home.scm (): Move home-fontconfig-service-type from
> home-environment-default-essential-services to its %home-base-services.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
> ---
>  gnu/home.scm               |  5 ++---
>  gnu/home/services/base.scm | 35 +++++++++++++++++++++++++++++++++++
>  gnu/local.mk               |  2 ++
>  3 files changed, 39 insertions(+), 3 deletions(-)
>  create mode 100644 gnu/home/services/base.scm
>
> diff --git a/gnu/home.scm b/gnu/home.scm
> index c95d1e0818..c79db87018 100644
> --- a/gnu/home.scm
> +++ b/gnu/home.scm
> @@ -19,10 +19,10 @@
>
>  (define-module (gnu home)
>    #:use-module (gnu home services)
> +  #:use-module (gnu home services base)
>    #:use-module (gnu home services symlink-manager)
>    #:use-module (gnu home services shells)
>    #:use-module (gnu home services xdg)
> -  #:use-module (gnu home services fontutils)
>    #:use-module (gnu services)
>    #:use-module (guix records)
>    #:use-module (guix diagnostics)
> @@ -66,7 +66,7 @@ (define-record-type* <home-environment> home-environment
>                                  this-home-environment)))
>
>    (services           home-environment-user-services
> -                      (default '()))
> +                      (default %home-base-services))
>
>    (location           home-environment-location            ; <location>
>                        (default (and=> (current-source-location)
> @@ -82,7 +82,6 @@ (define (home-environment-default-essential-services he)
>
>     (service home-symlink-manager-service-type)
>
> -   (service home-fontconfig-service-type)
>     (service home-xdg-base-directories-service-type)
>     (service home-shell-profile-service-type)
>
> diff --git a/gnu/home/services/base.scm b/gnu/home/services/base.scm
> new file mode 100644
> index 0000000000..fbf92ba213
> --- /dev/null
> +++ b/gnu/home/services/base.scm
> @@ -0,0 +1,35 @@
> +;;; GNU Guix --- Functional package management for GNU
> +;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
> +;;;
> +;;; This file is part of GNU Guix.
> +;;;
> +;;; GNU Guix is free software; you can redistribute it and/or modify it
> +;;; under the terms of the GNU General Public License as published by
> +;;; the Free Software Foundation; either version 3 of the License, or (at
> +;;; your option) any later version.
> +;;;
> +;;; GNU Guix is distributed in the hope that it will be useful, but
> +;;; WITHOUT ANY WARRANTY; without even the implied warranty of
> +;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
> +;;; GNU General Public License for more details.
> +;;;
> +;;; You should have received a copy of the GNU General Public License
> +;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
> +
> +(define-module (gnu home services base)
> +  #:use-module (gnu home services)
> +  #:use-module (gnu home services fontutils)
> +  #:export (%home-base-services))
> +
> +;;; Commentary:
> +;;
> +;; Base home services---i,e., services that 99% of the users will want to use.
> +;;
> +;;; Code:
> +
> +
> +(define %home-base-services
> +  ;; Convenience variable holding the basic services.
> +  (list (service home-fontconfig-service-type)))
> +
> +;;; base.scm ends here
> diff --git a/gnu/local.mk b/gnu/local.mk
> index 26fdfe7ca9..c0fceafd3f 100644
> --- a/gnu/local.mk
> +++ b/gnu/local.mk
> @@ -54,6 +54,7 @@
>  # Copyright © 2022 muradm <mail@muradm.net>
>  # Copyright © 2022 Hilton Chain <hako@ultrarare.space>
>  # Copyright © 2022 Alex Griffin <a@ajgrf.com>
> +# Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
>  #
>  # This file is part of GNU Guix.
>  #
> @@ -85,6 +86,7 @@ GNU_SYSTEM_MODULES =				\
>    %D%/compression.scm				\
>    %D%/home.scm					\
>    %D%/home/services.scm			\
> +  %D%/home/services/base.scm			\
>    %D%/home/services/desktop.scm			\
>    %D%/home/services/symlink-manager.scm		\
>    %D%/home/services/fontutils.scm		\

--
diff mbox series

Patch

diff --git a/gnu/home.scm b/gnu/home.scm
index c95d1e0818..c79db87018 100644
--- a/gnu/home.scm
+++ b/gnu/home.scm
@@ -19,10 +19,10 @@ 
 
 (define-module (gnu home)
   #:use-module (gnu home services)
+  #:use-module (gnu home services base)
   #:use-module (gnu home services symlink-manager)
   #:use-module (gnu home services shells)
   #:use-module (gnu home services xdg)
-  #:use-module (gnu home services fontutils)
   #:use-module (gnu services)
   #:use-module (guix records)
   #:use-module (guix diagnostics)
@@ -66,7 +66,7 @@  (define-record-type* <home-environment> home-environment
                                 this-home-environment)))
 
   (services           home-environment-user-services
-                      (default '()))
+                      (default %home-base-services))
 
   (location           home-environment-location            ; <location>
                       (default (and=> (current-source-location)
@@ -82,7 +82,6 @@  (define (home-environment-default-essential-services he)
 
    (service home-symlink-manager-service-type)
 
-   (service home-fontconfig-service-type)
    (service home-xdg-base-directories-service-type)
    (service home-shell-profile-service-type)
 
diff --git a/gnu/home/services/base.scm b/gnu/home/services/base.scm
new file mode 100644
index 0000000000..fbf92ba213
--- /dev/null
+++ b/gnu/home/services/base.scm
@@ -0,0 +1,35 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu home services base)
+  #:use-module (gnu home services)
+  #:use-module (gnu home services fontutils)
+  #:export (%home-base-services))
+
+;;; Commentary:
+;;
+;; Base home services---i,e., services that 99% of the users will want to use.
+;;
+;;; Code:
+
+
+(define %home-base-services
+  ;; Convenience variable holding the basic services.
+  (list (service home-fontconfig-service-type)))
+
+;;; base.scm ends here
diff --git a/gnu/local.mk b/gnu/local.mk
index 26fdfe7ca9..c0fceafd3f 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -54,6 +54,7 @@ 
 # Copyright © 2022 muradm <mail@muradm.net>
 # Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 # Copyright © 2022 Alex Griffin <a@ajgrf.com>
+# Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
 #
 # This file is part of GNU Guix.
 #
@@ -85,6 +86,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/compression.scm				\
   %D%/home.scm					\
   %D%/home/services.scm			\
+  %D%/home/services/base.scm			\
   %D%/home/services/desktop.scm			\
   %D%/home/services/symlink-manager.scm		\
   %D%/home/services/fontutils.scm		\