diff mbox series

[bug#58244] gnu: public-inbox: Update to 1.9.0.

Message ID 20221002040130.26238-1-bauermann@kolabnow.com
State Accepted
Headers show
Series [bug#58244] gnu: public-inbox: Update to 1.9.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Oct. 2, 2022, 4:01 a.m. UTC
The patch is included in version 1.9.0, so remove it from Guix.

* gnu/packages/patches/public-inbox-fix-spawn-test.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove patch.
* gnu/packages/mail.scm (public-inbox)[version]: Change to 1.9.0.
[source]: Update hash.  Remove patch.
---
 gnu/local.mk                                  |  1 -
 gnu/packages/mail.scm                         |  7 ++-
 .../patches/public-inbox-fix-spawn-test.patch | 43 -------------------
 3 files changed, 3 insertions(+), 48 deletions(-)
 delete mode 100644 gnu/packages/patches/public-inbox-fix-spawn-test.patch

Comments

Efraim Flashner Oct. 6, 2022, 2 p.m. UTC | #1
1.9.0 fails to build on i686-linux, where 1.8.0 has a substitute
available. Can you take a look at that before we commit this? Thanks.
Thiago Jung Bauermann Oct. 8, 2022, 11:11 p.m. UTC | #2
Hello Efraim,

Thank you for your review.

Efraim Flashner <efraim@flashner.co.il> writes:

> [[PGP Signed Part:Undecided]]
> 1.9.0 fails to build on i686-linux, where 1.8.0 has a substitute
> available. Can you take a look at that before we commit this? Thanks.

Ah, interesting. The problem was that for i686-linux public-inbox needs
the File::FcntlLock Perl module to support 64-bit off_t. Maybe other
32-bit targets need it too, but I don't have an easy way to test.

I'm sending a couple of patches fixing the problem for i686-linux.
Ludovic Courtès Oct. 9, 2022, 8:22 p.m. UTC | #3
Bom dia Thiago,

Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:

>   gnu: Add perl-file-fcntllock.
>   gnu: public-inbox: Update to 1.9.0.

Applied, thanks!

Ludo’.
Thiago Jung Bauermann Oct. 13, 2022, 3:01 a.m. UTC | #4
Boa noite Ludo, :-)

Ludovic Courtès <ludo@gnu.org> writes:

> Bom dia Thiago,
>
> Thiago Jung Bauermann <bauermann@kolabnow.com> skribis:
>
>>   gnu: Add perl-file-fcntllock.
>>   gnu: public-inbox: Update to 1.9.0.
>
> Applied, thanks!

Thank you!
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index 26fdfe7ca913..7cd0d25a89c0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1679,7 +1679,6 @@  dist_patch_DATA =						\
   %D%/packages/patches/psm-disable-memory-stats.patch		\
   %D%/packages/patches/psm-ldflags.patch			\
   %D%/packages/patches/psm-repro.patch				\
-  %D%/packages/patches/public-inbox-fix-spawn-test.patch	\
   %D%/packages/patches/pulseaudio-fix-mult-test.patch		\
   %D%/packages/patches/pulseaudio-longer-test-timeout.patch	\
   %D%/packages/patches/pulseview-qt515-compat.patch		\
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d806086205..8c7264397975 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4141,7 +4141,7 @@  (define-public l2md
 (define-public public-inbox
   (package
     (name "public-inbox")
-    (version "1.8.0")
+    (version "1.9.0")
     (source
      (origin (method git-fetch)
              (uri (git-reference
@@ -4149,9 +4149,8 @@  (define-public public-inbox
                    (commit (string-append "v" version))))
              (sha256
               (base32
-               "0xni1l54v1z3p0zb52807maay0yqabp8jgf5iras5zmhgjyk3swz"))
-             (file-name (git-file-name name version))
-             (patches (search-patches "public-inbox-fix-spawn-test.patch"))))
+               "0cgvxg0f32nvb3079x46gjkfis4bc98s6nx6kl8rm90kmb1kxkx9"))
+             (file-name (git-file-name name version))))
     (build-system perl-build-system)
     (arguments
      `(#:imported-modules (,@%perl-build-system-modules
diff --git a/gnu/packages/patches/public-inbox-fix-spawn-test.patch b/gnu/packages/patches/public-inbox-fix-spawn-test.patch
deleted file mode 100644
index 2739b1974de8..000000000000
--- a/gnu/packages/patches/public-inbox-fix-spawn-test.patch
+++ /dev/null
@@ -1,43 +0,0 @@ 
-From 5593489d9c3ce22b1942f35c7ebb0e06fcf2bfa8 Mon Sep 17 00:00:00 2001
-From: Thiago Jung Bauermann <bauermann@kolabnow.com>
-Date: Fri, 10 Jun 2022 12:39:18 -0300
-Subject: [PATCH] t/spawn: Find invalid PID to try to join its process group
-
-In the container used to build packages of the GNU Guix distribution, PID 1
-runs as the same user as the test so this spawn that should fail actually
-succeeds.
-
-Fix the problem by going through different PIDs and picking one that
-either doesn't exist or we aren't allowed to signal.
----
-
-This patch is taken from the public-inbox repository and will appear in the
-release after v1.8.
-
- t/spawn.t | 13 ++++++++++++-
- 1 file changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/t/spawn.t b/t/spawn.t
-index 6168c1f6171c..5fc99a2a101c 100644
---- a/t/spawn.t
-+++ b/t/spawn.t
-@@ -24,7 +24,18 @@ SKIP: {
- 	is(waitpid($pid, 0), $pid, 'waitpid succeeds on spawned process');
- 	is($?, 0, 'true exited successfully');
- 	pipe(my ($r, $w)) or BAIL_OUT;
--	$pid = eval { spawn(['true'], undef, { pgid => 1, 2 => $w }) };
-+
-+	# Find invalid PID to try to join its process group.
-+	my $wrong_pgid = 1;
-+	for (my $i=0x7fffffff; $i >= 2; $i--) {
-+		if (kill(0, $i) == 0) {
-+			$wrong_pgid = $i;
-+			last;
-+		}
-+	}
-+
-+	# Test spawn behavior when it can't join the requested process group.
-+	$pid = eval { spawn(['true'], undef, { pgid => $wrong_pgid, 2 => $w }) };
- 	close $w;
- 	my $err = do { local $/; <$r> };
- 	# diag "$err ($@)";