diff mbox series

[bug#58237] gnu: celluloid: Do not install icon cache.

Message ID 20221001225644.14960-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#58237] gnu: celluloid: Do not install icon cache. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Oct. 1, 2022, 10:56 p.m. UTC
Fixes <https://issues.guix.gnu.org/58207>.

* gnu/packages/video.scm (celluloid)[arguments]: Add phase
disable-postinstall-script so postinstall-script does nothing.
[native-inputs]: Remove gtk:bin.
---
 gnu/packages/video.scm | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

Comments

Efraim Flashner Oct. 6, 2022, 2 p.m. UTC | #1
Thanks. Patch pushed!

Make sure to check celluloid to see if it does indeed fix bug 58207.
diff mbox series

Patch

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6a14a85b74..f22c145b8f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -785,12 +785,19 @@  (define-public celluloid
        (sha256
         (base32 "0ns9xh582c8kajw4v2x5ap5jfiba3gxywqc2klc0v6fc3id1gqii"))))
     (build-system meson-build-system)
+    (arguments
+     (list
+      #:glib-or-gtk? #t
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'disable-postinstall-script
+            (lambda _
+              (setenv "DESTDIR" "/"))))))
     (native-inputs
      (list
       desktop-file-utils           ; for update-desktop-database
       intltool
       `(,glib "bin")               ; for glib-compile-resources
-      `(,gtk "bin")                ; for gtk-update-icon-cache
       pkg-config
       python-wrapper))             ; for generate-authors.py
     (inputs