diff mbox series

[bug#58213] gnu: emacs-ag: Do not propagate the-silver-searcher and use gexp.

Message ID 20221001053316.731-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#58213] gnu: emacs-ag: Do not propagate the-silver-searcher and use gexp. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Oct. 1, 2022, 5:33 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ag)[phases]: Use gexps.
{substitute-ag-path}: Add phase to avoid propagating ag.
{install-info}: Use gexps.
[inputs]: Add the-silver-searcher.
[propagated-inputs]: Remove the-silver-searcher.
---
 gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++--------------
 1 file changed, 18 insertions(+), 14 deletions(-)

Comments

Efraim Flashner Oct. 2, 2022, 6:14 p.m. UTC | #1
On Sat, Oct 01, 2022 at 07:33:16AM +0200, Michael Rohleder wrote:
> * gnu/packages/emacs-xyz.scm (emacs-ag)[phases]: Use gexps.
> {substitute-ag-path}: Add phase to avoid propagating ag.
> {install-info}: Use gexps.
> [inputs]: Add the-silver-searcher.
> [propagated-inputs]: Remove the-silver-searcher.
> ---
>  gnu/packages/emacs-xyz.scm | 32 ++++++++++++++++++--------------
>  1 file changed, 18 insertions(+), 14 deletions(-)
> 
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 6d9d0d6a8f..76a17da88e 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -3026,23 +3026,27 @@ (define-public emacs-ag
>          (base32 "1p918y24vcn2pdliaymd210xp9fvhd4a1srqbv2lfiqrh59yjidx"))))
>      (build-system emacs-build-system)
>      (arguments
> -     `(#:phases
> -       (modify-phases %standard-phases
> -         (add-before 'install 'make-info
> -           (lambda _
> -             (with-directory-excursion "docs"
> -               (invoke "make" "info"))))
> -         (add-after 'install 'install-info
> -           (lambda* (#:key outputs #:allow-other-keys)
> -             (let* ((out  (assoc-ref outputs "out"))
> -                    (info (string-append out "/share/info")))
> -               (install-file "docs/_build/texinfo/agel.info" info)))))))
> +     (list
> +      #:phases
> +      #~(modify-phases %standard-phases
> +          (add-after 'unpack 'substitute-ag-path
> +            (lambda _
> +              (make-file-writable "ag.el")
> +              (emacs-substitute-sexps "ag.el"
> +                ("defcustom ag-executable" (which "ag")))))
> +          (add-before 'install 'make-info
> +            (lambda _
> +              (with-directory-excursion "docs"
> +                (invoke "make" "info"))))
> +          (add-after 'install 'install-info
> +            (lambda _
> +              (install-file "docs/_build/texinfo/agel.info"
> +                            (string-append #$output "/share/info")))))))
> +    (inputs (list the-silver-searcher))  ;'ag' executable
>      (native-inputs
>       (list python-sphinx texinfo))
>      (propagated-inputs
> -     (list emacs-dash
> -           emacs-s
> -           the-silver-searcher))        ;'ag' executable
> +     (list emacs-dash emacs-s))
>      (home-page "https://github.com/Wilfred/ag.el")
>      (synopsis "Front-end for ag (the-silver-searcher) for Emacs")
>      (description "This package provides the ability to use the silver
> -- 
> 2.37.3
> 

Can you split this into two patches? The first to not propagate the
silver searcher and the second to switch to gexps? Thanks.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6d9d0d6a8f..76a17da88e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -3026,23 +3026,27 @@  (define-public emacs-ag
         (base32 "1p918y24vcn2pdliaymd210xp9fvhd4a1srqbv2lfiqrh59yjidx"))))
     (build-system emacs-build-system)
     (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (add-before 'install 'make-info
-           (lambda _
-             (with-directory-excursion "docs"
-               (invoke "make" "info"))))
-         (add-after 'install 'install-info
-           (lambda* (#:key outputs #:allow-other-keys)
-             (let* ((out  (assoc-ref outputs "out"))
-                    (info (string-append out "/share/info")))
-               (install-file "docs/_build/texinfo/agel.info" info)))))))
+     (list
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-after 'unpack 'substitute-ag-path
+            (lambda _
+              (make-file-writable "ag.el")
+              (emacs-substitute-sexps "ag.el"
+                ("defcustom ag-executable" (which "ag")))))
+          (add-before 'install 'make-info
+            (lambda _
+              (with-directory-excursion "docs"
+                (invoke "make" "info"))))
+          (add-after 'install 'install-info
+            (lambda _
+              (install-file "docs/_build/texinfo/agel.info"
+                            (string-append #$output "/share/info")))))))
+    (inputs (list the-silver-searcher))  ;'ag' executable
     (native-inputs
      (list python-sphinx texinfo))
     (propagated-inputs
-     (list emacs-dash
-           emacs-s
-           the-silver-searcher))        ;'ag' executable
+     (list emacs-dash emacs-s))
     (home-page "https://github.com/Wilfred/ag.el")
     (synopsis "Front-end for ag (the-silver-searcher) for Emacs")
     (description "This package provides the ability to use the silver