diff mbox series

[bug#58211,3/4] gnu: python-matrix-nio: Update to 0.20.0.

Message ID 20221001042726.28433-4-mike@rohleder.de
State Accepted
Headers show
Series gnu: pantalaimon: Update to 0.10.5 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Oct. 1, 2022, 4:27 a.m. UTC
* gnu/packages/matrix.scm (python-matrix-nio): Update to 0.20.0.
[native-inputs]: Add python-pytest-asyncio.
[propagated-inputs]: Changed python-jsonschema to python-jsonschema-next.
---
 gnu/packages/matrix.scm | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/matrix.scm b/gnu/packages/matrix.scm
index 2ba6d8ba1f..8e543f0a91 100644
--- a/gnu/packages/matrix.scm
+++ b/gnu/packages/matrix.scm
@@ -1,7 +1,7 @@ 
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
 ;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2020, 2021 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2021, 2022 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2022 Morgan Smith <Morgan.J.Smith@outlook.com>
@@ -158,13 +158,13 @@  (define-public synapse
 (define-public python-matrix-nio
   (package
     (name "python-matrix-nio")
-    (version "0.18.7")
+    (version "0.20.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "matrix-nio" version))
        (sha256
-        (base32 "0cw4y6dx8n8hynxqlzzkj8p34nfbc2xryvmkr5yhmja31y4rks4k"))))
+        (base32 "1ycrp48b15nm2d3w3qpzps21czl3gbikadl10sncbzr9wdwn44g4"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -191,6 +191,7 @@  (define-public python-matrix-nio
        ("python-hpack" ,python-hpack)
        ("python-faker" ,python-faker)
        ("python-pytest-aiohttp" ,python-pytest-aiohttp)
+       ("python-pytest-asyncio" ,python-pytest-asyncio)
        ("python-aioresponses" ,python-aioresponses)
        ("python-pytest-benchmark" ,python-pytest-benchmark)
        ("python-toml" ,python-toml)
@@ -206,7 +207,7 @@  (define-public python-matrix-nio
            (file-name (git-file-name name version))
            (sha256
             (base32
-             "152prkndk53pfxm4in4xak4hwzyaxlbp6wv2zbk2xpzgyy9bvn3s"))))))
+             "10j8g3ns3v1ghdn262dxg50ayaczdp1hj97pj4ydw02bncqhddpd"))))))
     (propagated-inputs
      (list python-aiofiles
            python-aiohttp
@@ -216,7 +217,7 @@  (define-public python-matrix-nio
            python-future
            python-h11
            python-h2
-           python-jsonschema
+           python-jsonschema-next
            python-logbook
            python-olm
            python-peewee