diff mbox series

[bug#58211,1/4] gnu: python-socks: Update to 2.0.3.

Message ID 20221001042726.28433-2-mike@rohleder.de
State Accepted
Headers show
Series gnu: pantalaimon: Update to 0.10.5 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Oct. 1, 2022, 4:27 a.m. UTC
* gnu/packages/python-web.scm (python-socks): Update to 2.0.3.
[arguments]<#:phases>: Remove trailing #t.
---
 gnu/packages/python-web.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 94544e1e74..f1eb4fb7b5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -6555,14 +6555,14 @@  (define-public python-socketio
 (define-public python-socks
   (package
     (name "python-socks")
-    (version "1.2.4")
+    (version "2.0.3")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "python-socks" version))
        (sha256
         (base32
-         "1n6xb18jy41ybgkmamakg6psp3qididd45qknxiggngaiibz43kx"))))
+         "12msk06c0glljcrx1byd78xgv05lxw81vknqwhn8ccs7an7cmag3"))))
     (build-system python-build-system)
     (arguments
      `(#:tests? #f                      ; tests not included
@@ -6571,8 +6571,7 @@  (define-public python-socks
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
              (when tests?
-               (invoke "pytest" "tests/" "-s"))
-             #t)))))
+               (invoke "pytest" "tests/" "-s")))))))
     (propagated-inputs
      (list python-async-timeout python-curio python-trio))
     (native-inputs