diff mbox series

[bug#58189] gnu: squid: Enable TLS features

Message ID 20220930073439.2317-1-sarg@sarg.org.ru
State Accepted
Headers show
Series [bug#58189] gnu: squid: Enable TLS features | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Sergey Trofimov Sept. 30, 2022, 7:34 a.m. UTC
I've noticed that despite openssl is listed as an input - it's not actually enabled by default.
Fixing that using a configure flag. W/o this change I was not able to use cache_peer with tls enabled.

---
 gnu/packages/networking.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès Oct. 6, 2022, 9:10 p.m. UTC | #1
Hi,

Sergey Trofimov <sarg@sarg.org.ru> skribis:

> I've noticed that despite openssl is listed as an input - it's not actually enabled by default.
> Fixing that using a configure flag. W/o this change I was not able to use cache_peer with tls enabled.

I tweaked the commit log and applied it, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3d9ba4fc8d..3489c3b96a 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2010,7 +2010,7 @@  (define-public squid
      '(#:configure-flags
        ;; disable -march=native in build for reproducibility; see
        ;; https://wiki.squid-cache.org/KnowledgeBase/IllegalInstructionError
-       (list "--disable-arch-native")
+       (list "--disable-arch-native" "--with-openssl")
        #:phases
        (modify-phases %standard-phases
          (add-before 'build 'fix-true-path