diff mbox series

[bug#58179,3/4] gnu: Add node-chrome-remote-interface.

Message ID 20220929195227.11018-3-ngraves@ngraves.fr
State New
Headers show
Series [bug#58179,1/4] gnu: Add node-ws. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Sept. 29, 2022, 7:52 p.m. UTC
* gnu/packages/node-xyz.scm (node-chrome-remote-interface): New variable.
---
 gnu/packages/node-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/node-xyz.scm b/gnu/packages/node-xyz.scm
index c14ff7f421..8dd11333ef 100644
--- a/gnu/packages/node-xyz.scm
+++ b/gnu/packages/node-xyz.scm
@@ -85,6 +85,36 @@  (define-public node-buffer-crc32
 and fancy character sets, signed or unsigned data and has tests, for Node.")
     (license license:expat)))
 
+(define-public node-chrome-remote-interface
+  (package
+    (name "node-chrome-remote-interface")
+    (version "0.31.3")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/cyrus-and/chrome-remote-interface")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0gbz8cj6s1mxvzaa9wpvdky2mcrdaz3ql552rkzzi6xlziqsrx69"))))
+    (build-system node-build-system)
+    (arguments
+     '(#:tests? #f
+       #:phases (modify-phases %standard-phases
+                  (replace 'configure
+                    (lambda _
+                      (invoke "npm" "--offline" "--ignore-scripts" "install"
+                              "--production"))))))
+    (inputs (list node-ws node-commander))
+    (home-page "https://github.com/cyrus-and/chrome-remote-interface")
+    (synopsis "Chrome Debugging Protocol interface")
+    (description "This package is a Chrome Debugging Protocol interface that
+helps to instrument Chrome (or any other suitable implementation) by providing
+a simple abstraction of commands and notifications using a straightforward
+JavaScript API.")
+    (license license:expat)))
+
 (define-public node-color-name
   (package
     (name "node-color-name")