diff mbox series

[bug#58160] gnu: ghc-lucid: fix: cabal-revision

Message ID 20220929131715.234490-1-contact@phfrohring.com
State Accepted
Headers show
Series [bug#58160] gnu: ghc-lucid: fix: cabal-revision | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Pierre-Henry Fröhring Sept. 29, 2022, 1:17 p.m. UTC
The `cabal-revision' changed from:

  1f0whk5ncanxfjjanrf6rqyncig2xgc5mh2j0sqy3nrlyjr9aqq9

to:

  1xllyf26ypk37k807g5v6fl1449mhpvk18dljmqgwj723n0v8rpj

This patch fixes it.
---
 gnu/packages/haskell-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Ludovic Courtès Oct. 14, 2022, 10:40 p.m. UTC | #1
Hi,

Pierre-Henry Fröhring <contact@phfrohring.com> skribis:

> The `cabal-revision' changed from:
>
>   1f0whk5ncanxfjjanrf6rqyncig2xgc5mh2j0sqy3nrlyjr9aqq9
>
> to:
>
>   1xllyf26ypk37k807g5v6fl1449mhpvk18dljmqgwj723n0v8rpj
>
> This patch fixes it.

Lars, could you take a look?

I’m discovering #:cabal-revision and it’s not clear to me what this hash
is and what it is used for.

Thanks,
Ludo’.
Lars-Dominik Braun Oct. 15, 2022, 8:26 a.m. UTC | #2
Hi Ludo,

> Lars, could you take a look?
applied as 4c896c226db8036fa4fb5630ff890abefcd97fe1.

> I’m discovering #:cabal-revision and it’s not clear to me what this hash
> is and what it is used for.
Hackage provides updated .cabal package descriptions i.e., to update
dependency version ranges. Unfortunately haskell-build-system has this
extra quirk to fetch them. Since the importer does not update
cabal-revision when updating the version this was missed when I did the
last big Haskell update. Would be nice if we could merge multiple origins
in the source field.

Cheers,
Lars
Simon Tournier Oct. 15, 2022, 11:51 a.m. UTC | #3
Hi Ludo,

On Sat, 15 Oct 2022 at 00:40, Ludovic Courtès <ludo@gnu.org> wrote:

> I’m discovering #:cabal-revision and it’s not clear to me what this hash
> is and what it is used for.

FYI, this #:cabal-revision should go to ’origin’ and not ’arguments’; as
explained here [1].

1: <https://yhetil.org/guix/87ilmk5q8q.fsf@gmail.com>


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index db653f8c93..49db7ad25d 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -7217,7 +7217,7 @@  (define-public ghc-lucid
     (arguments
      `(#:cabal-revision
        ("1"
-        "1f0whk5ncanxfjjanrf6rqyncig2xgc5mh2j0sqy3nrlyjr9aqq9")))
+        "1xllyf26ypk37k807g5v6fl1449mhpvk18dljmqgwj723n0v8rpj")))
     (home-page "https://github.com/chrisdone/lucid")
     (synopsis "Haskell DSL for rendering HTML")
     (description "Clear to write, read and edit Haskell DSL for HTML.