@@ -10672,6 +10672,35 @@ (define-public go-github-com-niemeyer-pretty
terminal.")
(license license:expat)))
+(define-public go-github-com-arran4-golang-ical
+ (package
+ (name "go-github-com-arran4-golang-ical")
+ (version "0.0.0-20220517104411-fd89fefb0182")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/arran4/golang-ical")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0bxs0b5yg26liiifc0cc41l307r0wc93hp8iygv8dgpc60yzncaw"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/arran4/golang-ical"))
+ (propagated-inputs (list go-gopkg-in-yaml-v3
+ go-gopkg-in-check-v1
+ go-github-com-stretchr-testify
+ go-github-com-niemeyer-pretty
+ go-github-com-kr-text
+ go-github-com-davecgh-go-spew))
+ (home-page "https://github.com/arran4/golang-ical")
+ (synopsis "Handle iCalenders in Go")
+ (description
+ "The @code{ical} package provides an ICS/iCalender parser and
+serialiser for Go.")
+ (license license:asl2.0)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
From: "(unmatched-parenthesis" <paren@disroot.org> * gnu/packages/golang.scm (go-github-com-arran4-golang-ical): New variable. --- gnu/packages/golang.scm | 29 +++++++++++++++++++++++++++++ 1 file changed, 29 insertions(+)