diff mbox series

[bug#58058,1/1] gnu: Add emacs-ol-notmuch.

Message ID 20220925015013.642511-1-plattfot@posteo.net
State Accepted
Headers show
Series Add emacs-ol-notmuch | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Fredrik Salomonsson Sept. 25, 2022, 1:50 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ol-notmuch): New variable.
---
 gnu/packages/emacs-xyz.scm | 39 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

Comments

Nicolas Goaziou Sept. 25, 2022, 1:23 p.m. UTC | #1
Hello,

Fredrik Salomonsson <plattfot@posteo.net> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ol-notmuch): New variable.

Applied. Thank you.

> +     (description
> +      "This package implements links to notmuch messages and \"searches\" for
> +Emacs' Org mode. A search is a query to be performed by notmuch; it is the
> +equivalent to folders in other mail clients. Similarly, mails are referred to
> +by a query, so both a link can refer to several mails.
> +
> +Links have one the following forms - notmuch:<search terms> -
> +notmuch-search:<search terms>.
> +
> +The first form open the queries in `notmuch-show-mode', whereas the
> +second link open it in `notmuch-search-mode'. Note that queries are
> +performed at the time the link is opened, and the result may be
> +different from when the link was stored.")

I removed the two last paragraphs, which belong to the documentation
rather than a description. I also separated sentences with two spaces,
as requested by Texinfo markup.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0e3e0be3b8..1e30079e56 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7009,6 +7009,45 @@  (define-public emacs-ob-async
 src blocks.")
     (license license:gpl3+)))
 
+(define-public emacs-ol-notmuch
+  (let ((commit "1a53d6c707514784cabf33d865b577bf77f45913")
+        (revision "0"))
+    (package
+     (name "emacs-ol-notmuch")
+     (version (git-version "2.0.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.sr.ht/~tarsius/ol-notmuch")
+             (commit commit)))
+       (sha256
+        (base32
+         "16p7j51z8r047alwn2hkb6944f7ds29ckb97b4k8ia00vwch0d67"))
+       (file-name (git-file-name name version))))
+     (build-system emacs-build-system)
+     (propagated-inputs
+      (list
+       emacs-compat
+       emacs-notmuch
+       emacs-org))
+     (home-page "https://git.sr.ht/~tarsius/ol-notmuch")
+     (synopsis "Links to notmuch messages for Emacs' Org mode")
+     (description
+      "This package implements links to notmuch messages and \"searches\" for
+Emacs' Org mode. A search is a query to be performed by notmuch; it is the
+equivalent to folders in other mail clients. Similarly, mails are referred to
+by a query, so both a link can refer to several mails.
+
+Links have one the following forms - notmuch:<search terms> -
+notmuch-search:<search terms>.
+
+The first form open the queries in `notmuch-show-mode', whereas the
+second link open it in `notmuch-search-mode'. Note that queries are
+performed at the time the link is opened, and the result may be
+different from when the link was stored.")
+     (license license:gpl3+))))
+
 (define-public emacs-debbugs
   (package
     (name "emacs-debbugs")