diff mbox series

[bug#58022,2/2] python-protontricks: New package

Message ID 20220923121548.27503-2-kreyren@rixotstudio.cz
State Accepted
Headers show
Series None | expand

Commit Message

Jacob Hrbek Sept. 23, 2022, 12:16 p.m. UTC
---
 gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

--
2.37.3

Comments

Ludovic Courtès Sept. 29, 2022, 8:47 p.m. UTC | #1
Hi,

Jacob Hrbek <kreyren@rixotstudio.cz> skribis:

> +    (home-page "https://github.com/Matoking/protontricks")
> +    (synopsis
> +     "A simple wrapper for running Winetricks commands for Proton-enabled games.")
> +    (description
> +     "This package provides a simple wrapper for running Winetricks commands for
> +Proton-enabled games.")

I did not understand much of this description so I dig a bit and found
that Winetricks is a requirement for Protontricks, and that Winetricks
is a script to download non-free Windows software¹.  Did I get it right?

If that characterization is correct, we will not included in Guix as it
would contradict the Free System Distribution Guidelines (FSDG) that the
project follows, specifically the bit about not providing “recipes for
installation of particular nonfree programs”.

Thanks,
Ludo’.

¹ https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
Jacob Hrbek Oct. 1, 2022, 5:34 p.m. UTC | #2
Fair, thanks for noticing it


-- Jacob "Kreyren" Hrbek

Sent with Proton Mail secure email.

------- Original Message -------
On Thursday, September 29th, 2022 at 10:47 PM, Ludovic Courtès <ludo@gnu.org> wrote:


> Hi,
> 
> Jacob Hrbek kreyren@rixotstudio.cz skribis:
> 
> > + (home-page "https://github.com/Matoking/protontricks")
> > + (synopsis
> > + "A simple wrapper for running Winetricks commands for Proton-enabled games.")
> > + (description
> > + "This package provides a simple wrapper for running Winetricks commands for
> > +Proton-enabled games.")
> 
> 
> I did not understand much of this description so I dig a bit and found
> that Winetricks is a requirement for Protontricks, and that Winetricks
> is a script to download non-free Windows software¹. Did I get it right?
> 
> If that characterization is correct, we will not included in Guix as it
> would contradict the Free System Distribution Guidelines (FSDG) that the
> project follows, specifically the bit about not providing “recipes for
> installation of particular nonfree programs”.
> 
> Thanks,
> Ludo’.
> 
> ¹ https://raw.githubusercontent.com/Winetricks/winetricks/master/src/winetricks
M Oct. 4, 2022, 4:46 p.m. UTC | #3
On 23-09-2022 14:16, Jacob Hrbek wrote:
> +              (method url-fetch)
> +              (uri (pypi-uri "protontricks" version))
> +              (sha256
> +               (base32
> +                "0kbq52p51k9j98kr23ljzhzmpnxnl9g6x3dxj27gqkshvnsinmjg"))))
> +    (build-system python-build-system)
> +    (inputs (list python-setuptools python-vdf python-wheel
> +                  python-setuptools-scm))
> +    (home-page"https://github.com/Matoking/protontricks")
> +    (synopsis
> +     "A simple wrapper for running Winetricks commands for Proton-enabled games.")
> +    (description
> +     "This package provides a simple wrapper for running Winetricks commands for
> +Proton-enabled games.")
> +    (license license:gpl3)))

The Winetricks contain non-free software, though (which additionally is 
unlikely to be gpl3)?  E.g., one of its main uses is to install 
Microsoft's .NET implementation instead of Mono (this was at a time when 
it didn't have a free license IIRC).  More contemporary, going by 
https://github.com/Winetricks/winetricks/blob/master/files/verbs/dlls.txt , 
it downloads many other Microsoft things -- while some of them might be 
free, I would expect most of them to be non-free.

To compare with another distro, in Debian, it is sorted in 'contrib'.

Also, going by a 'Re: Hostile takeover of the matrix room', you are 
banned.  That means you aren't allowed to send messages to Guix anymore. 
Given there appear to be some technical problems involving debbugs, I'll 
try setting up a local filter.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 473c3df26b..dc0bd0d931 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6408,6 +6408,27 @@  (define-public python-proto-matcher
 @end table")
     (license license:asl2.0)))

+(define-public python-protontricks
+  (package
+    (name "python-protontricks")
+    (version "1.9.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "protontricks" version))
+              (sha256
+               (base32
+                "0kbq52p51k9j98kr23ljzhzmpnxnl9g6x3dxj27gqkshvnsinmjg"))))
+    (build-system python-build-system)
+    (inputs (list python-setuptools python-vdf python-wheel
+                  python-setuptools-scm))
+    (home-page "https://github.com/Matoking/protontricks")
+    (synopsis
+     "A simple wrapper for running Winetricks commands for Proton-enabled games.")
+    (description
+     "This package provides a simple wrapper for running Winetricks commands for
+Proton-enabled games.")
+    (license license:gpl3)))
+
 (define-public python-matplotlib
   (package
     (name "python-matplotlib")