diff mbox series

[bug#58022,1/2] python-vdf: New package

Message ID 20220923121548.27503-1-kreyren@rixotstudio.cz
State Accepted
Headers show
Series python-protontricks: New packages + python-vdf dependency | expand

Commit Message

Jacob Hrbek Sept. 23, 2022, 12:15 p.m. UTC
---
 gnu/packages/python-xyz.scm | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)


base-commit: 3c4024e9f50a064d6458875623eb199a882feb53
--
2.37.3
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 92e0c9dbe8..473c3df26b 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15679,6 +15679,22 @@  (define-public python-multiprocessing-logging
 main process so that they are handled correctly.")
     (license license:lgpl3+)))

+(define-public python-vdf
+  (package
+    (name "python-vdf")
+    (version "3.4")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "vdf" version))
+              (sha256
+               (base32
+                "1bz2gn04pl6rj2mawlzlirz1ygg4rdypq0pxbyg018873vs1jm7x"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/ValvePython/vdf")
+    (synopsis "Library for working with Valve's VDF text format")
+    (description "Library for working with Valve's VDF text format")
+    (license license:expat)))
+
 (define-public python-vobject
   (package
     (name "python-vobject")