diff mbox series

[bug#57980] gnu: Add emacs-piem.

Message ID 20220921140912.2065383-1-zimon.toutoune@gmail.com
State Accepted
Headers show
Series [bug#57980] gnu: Add emacs-piem. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Simon Tournier Sept. 21, 2022, 2:09 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-piem): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)


base-commit: 6885f22375b093c08d69bbed6aa42d2e8c11a168

Comments

Nicolas Goaziou Sept. 24, 2022, 6:57 p.m. UTC | #1
Hello,

zimoun <zimon.toutoune@gmail.com> writes:

> * gnu/packages/emacs-xyz.scm (emacs-piem): New variable.

Thank you. Applied with the following changes:

> +    (source
> +     (origin
> +       (method git-fetch)
> +       (uri (git-reference
> +             (url "https://git.kyleam.com/piem.git")

I removed ".git" suffix.

> +             (commit (string-append "v" version))))
> +       (file-name (string-append name "-" version "-checkout"))
> +       (sha256
> +        (base32 "0wr6n6wvznngjdp4c0pmdr4xz05dark0kxi5svzhzxsg3rdaql3z"))))
> +    (build-system emacs-build-system)
> +    (propagated-inputs
> +     (list b4

This need to be moved to inputs, along with an appropriate phase. I'll
do this in a later commit.

> +    (description "This packages provides a collection of Emacs libraries for
> +working with public-inbox archives. As much of the hard work here is already
> +done by other Emacs libraries—things like mail clients, news readers, Git
> +interfaces, and even web browsers—piem is mostly about bridging some of these
> +parts for convenience.")

I added two spaces between sentences.

> +    (license license:gpl3)))

License is actually GPL3+ (I forgot to change it, I'll do this in
a later commit too)

Regards,
Simon Tournier Sept. 25, 2022, 11:19 a.m. UTC | #2
Hi,

On Sat, 24 Sep 2022 at 20:57, Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:

> Thank you. Applied with the following changes:

Oh my bad.  Thank you for the fixes.


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 32e4c33f16..03ad569300 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -7011,6 +7011,34 @@  (define-public emacs-debbugs
 Tracker as well as bug identifiers prepared for @code{bug-reference-mode}.")
     (license license:gpl3+)))
 
+(define-public emacs-piem
+  (package
+    (name "emacs-piem")
+    (version "0.4.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.kyleam.com/piem.git")
+             (commit (string-append "v" version))))
+       (file-name (string-append name "-" version "-checkout"))
+       (sha256
+        (base32 "0wr6n6wvznngjdp4c0pmdr4xz05dark0kxi5svzhzxsg3rdaql3z"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     (list b4
+           emacs-elfeed
+           emacs-notmuch
+           emacs-transient))
+    (home-page "https://docs.kyleam.com/piem")
+    (synopsis "Glue for working with public-inbox archives")
+    (description "This packages provides a collection of Emacs libraries for
+working with public-inbox archives. As much of the hard work here is already
+done by other Emacs libraries—things like mail clients, news readers, Git
+interfaces, and even web browsers—piem is mostly about bridging some of these
+parts for convenience.")
+    (license license:gpl3)))
+
 (define-public emacs-ert-expectations
   (package
     (name "emacs-ert-expectations")