diff mbox series

[bug#57924] gnome-todo is now endeavor + version bump

Message ID 20220919062444.9844-1-kreyren@rixotstudio.cz
State Accepted
Headers show
Series [bug#57924] gnome-todo is now endeavor + version bump | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jacob Hrbek Sept. 19, 2022, 6:24 a.m. UTC
---
 gnu/packages/gnome.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

--
2.37.3

Comments

M Sept. 19, 2022, 1:56 p.m. UTC | #1
merge 57675 57674
thanks

On 19-09-2022 08:24, Jacob Hrbek wrote:
> -(define-public gnome-todo
> +(define-public endeavour
>     (package
> -    (name "gnome-todo")
> -    (version "41.0")
> +    (name "endeavour")
> +    (version "42.0")
>       (source (origin
>                 (method url-fetch)
>                 (uri (string-append "mirror://gnome/sources/" name "/"

You forgot to adjust the hash.  As such, if it builds, it uses the 
source code corresponding to the old hash -- i.e., it effectively builds 
gnome-todo@41.0.

Greetings,
Maxime.
M Sept. 19, 2022, 1:59 p.m. UTC | #2
merge 57924 57295
thanks
Jacob Hrbek Sept. 19, 2022, 8:49 p.m. UTC | #3
>> You forgot to adjust the hash. As such, if it builds, it uses the
>> source code corresponding to the old hash -- i.e., it effectively builds
>> gnome-todo@41.0.

Didn't know it works that way thanks

------- Original Message -------
On Monday, September 19th, 2022 at 3:56 PM, Maxime Devos <maximedevos@telenet.be> wrote:


> merge 57675 57674
> thanks
> 

> On 19-09-2022 08:24, Jacob Hrbek wrote:
> 

> > -(define-public gnome-todo
> > +(define-public endeavour
> > (package
> > - (name "gnome-todo")
> > - (version "41.0")
> > + (name "endeavour")
> > + (version "42.0")
> > (source (origin
> > (method url-fetch)
> > (uri (string-append "mirror://gnome/sources/" name "/"
> 

> 

> You forgot to adjust the hash. As such, if it builds, it uses the
> source code corresponding to the old hash -- i.e., it effectively builds
> gnome-todo@41.0.
> 

> Greetings,
> Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 282c388b18..e12b96ca80 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10245,10 +10245,10 @@  (define-public gnome-calendar
 desktop.  It supports multiple calendars, month, week and year view.")
     (license license:gpl3+)))

-(define-public gnome-todo
+(define-public endeavour
   (package
-    (name "gnome-todo")
-    (version "41.0")
+    (name "endeavour")
+    (version "42.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnome/sources/" name "/"