diff mbox series

[bug#57809] gnome-boxes: Patch 'qemu-img' path

Message ID 20220919040932.5298-1-kreyren@rixotstudio.cz
State Accepted
Headers show
Series [bug#57809] gnome-boxes: Patch 'qemu-img' path | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jacob Hrbek Sept. 19, 2022, 4:09 a.m. UTC
---
 gnu/packages/gnome.scm | 12 +++++++++---
 1 file changed, 9 insertions(+), 3 deletions(-)

            gettext-minimal
@@ -12162,6 +12167,7 @@ (define-public gnome-boxes
            sparql-query
            spice-gtk
            tracker
+           qemu-minimal                 ;for qemu-img
            vte
            webkitgtk-with-libsoup2))    ;for webkit2gtk-4.0
     (home-page "https://wiki.gnome.org/Apps/Boxes")
--
2.37.3

Comments

M Sept. 19, 2022, 1:41 p.m. UTC | #1
On 19-09-2022 06:09, Jacob Hrbek wrote:
> +                          (setenv "DESTDIR" "/")))
> +                      (add-before 'configure 'substitute-qemu-dependencies
> +                        (lambda* (#:key inputs #:allow-other-keys)
> +
>                  (substitute* "src/installed-media.vala"
> +                              (("qemu-img")
> +                               (search-input-file inputs "/bin/qemu-img"))))))))

Aside from the indentation (which would IIUC be corrected by "guix 
style", see point (5) of the checklist in "(guix)Submitting Patches")) ...

>       (native-inputs
>        (list desktop-file-utils           ;for update-desktop-database
>              gettext-minimal
> @@ -12162,6 +12167,7 @@ (define-public gnome-boxes
>              sparql-query
>              spice-gtk
>              tracker


> +           qemu-minimal                 ;for qemu-img

... and the non-alphabetical sorting, ...

>              vte
>              webkitgtk-with-libsoup2))    ;for webkit2gtk-4.0

... looks good to me (though to be clear, I did not test the changes), 
though those problems can be addressed by the committer (just a note for 
future submissions).

Greetings,
Maxime.
Ludovic Courtès Sept. 26, 2022, 9:03 p.m. UTC | #2
Hi,

Jacob Hrbek <kreyren@rixotstudio.cz> skribis:

> ---
>  gnu/packages/gnome.scm | 12 +++++++++---
>  1 file changed, 9 insertions(+), 3 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index d6d22f8eb1..ff5cb92907 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -12131,9 +12131,14 @@ (define-public gnome-boxes
>                                                      #$output
>                                                      "/lib/gnome-boxes"))
>             #:phases #~(modify-phases %standard-phases
> -                        (add-after 'unpack 'disable-gtk-update-icon-cache
> -                          (lambda _
> -                            (setenv "DESTDIR" "/"))))))
> +                      (add-after 'unpack 'disable-gtk-update-icon-cache
> +                        (lambda _
> +                          (setenv "DESTDIR" "/")))
> +                      (add-before 'configure 'substitute-qemu-dependencies
> +                        (lambda* (#:key inputs #:allow-other-keys)
> +
>                 (substitute* "src/installed-media.vala"
> +                              (("qemu-img")
> +                               (search-input-file inputs "/bin/qemu-img"))))))))

Applied with minor tweaks and a commit log, thanks!|

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d6d22f8eb1..ff5cb92907 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -12131,9 +12131,14 @@  (define-public gnome-boxes
                                                     #$output
                                                     "/lib/gnome-boxes"))
            #:phases #~(modify-phases %standard-phases
-                        (add-after 'unpack 'disable-gtk-update-icon-cache
-                          (lambda _
-                            (setenv "DESTDIR" "/"))))))
+                      (add-after 'unpack 'disable-gtk-update-icon-cache
+                        (lambda _
+                          (setenv "DESTDIR" "/")))
+                      (add-before 'configure 'substitute-qemu-dependencies
+                        (lambda* (#:key inputs #:allow-other-keys)
+
                (substitute* "src/installed-media.vala"
+                              (("qemu-img")
+                               (search-input-file inputs "/bin/qemu-img"))))))))
     (native-inputs
      (list desktop-file-utils           ;for update-desktop-database