diff mbox series

[bug#57918] gnu: font-ibm-plex: Use git source.

Message ID 20220918220937.7722-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#57918] gnu: font-ibm-plex: Use git source. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Arun Isaac Sept. 18, 2022, 10:09 p.m. UTC
* gnu/packages/fonts.scm (font-ibm-plex)[source]: Use git source.
---
 gnu/packages/fonts.scm | 14 +++++++++-----
 1 file changed, 9 insertions(+), 5 deletions(-)

Comments

Ludovic Courtès Oct. 14, 2022, 10:43 p.m. UTC | #1
Arun Isaac <arunisaac@systemreboot.net> skribis:

> * gnu/packages/fonts.scm (font-ibm-plex)[source]: Use git source.

Got for it!  :-)

Ludo'.
Arun Isaac Oct. 15, 2022, 9:15 a.m. UTC | #2
Ludovic Courtès <ludo@gnu.org> writes:

> Arun Isaac <arunisaac@systemreboot.net> skribis:
>
>> * gnu/packages/fonts.scm (font-ibm-plex)[source]: Use git source.
>
> Got for it!  :-)

Pushed, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index cf3892ae8d..83e3a2c945 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -118,14 +118,18 @@  (define-public font-ibm-plex
   (package
     (name "font-ibm-plex")
     (version "6.1.1")
+    ;; We prefer git-fetch since it lets us get the opentype, truetype and web
+    ;; fonts all in one download. The zip archive releases separate the
+    ;; opentype, truetype and web fonts into three separate archives.
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/IBM/plex/releases/download/"
-                    "v" version "/OpenType.zip"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/IBM/plex")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1z9nxac9ha6gqz5yvfy5lp6hyl39f8f8hdrw3llcp89rdpjfqdn9"))))
+                "1jxyd0zl7jssn7mwz8x5xvjmw59x4mn82s2kywf9583k1pg949k1"))))
     (build-system font-build-system)
     (home-page "https://github.com/IBM/plex")
     (synopsis "IBM Plex typeface")