diff mbox series

[bug#57901] New package idevicerestore + ilibrecovery

Message ID 20220918063528.6074-1-kreyren@rixotstudio.cz
State Accepted
Headers show
Series [bug#57901] New package idevicerestore + ilibrecovery | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jacob Hrbek Sept. 18, 2022, 6:35 a.m. UTC
---
 gnu/packages/libusb.scm | 49 +++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)

   (package
     (name "libimobiledevice")
--
2.37.1

Comments

Jacob Hrbek Sept. 18, 2022, 8 a.m. UTC | #1
Submitted by mistake

On Ne, zář 18 2022 at 06:36:02 +0000, help-debbugs@gnu.org wrote:
> Thank you for filing a new bug report with debbugs.gnu.org.
> 
> This is an automatically generated reply to let you know your message
> has been received.
> 
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
> 
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org <mailto:guix-patches@gnu.org>
> 
> If you wish to submit further information on this problem, please
> send it to 57901@debbugs.gnu.org <mailto:57901@debbugs.gnu.org>.
> 
> Please do not send mail to help-debbugs@gnu.org 
> <mailto:help-debbugs@gnu.org> unless you wish
> to report a problem with the Bug-tracking system.
> 
> --
> 57901: <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=57901>
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org <mailto:help-debbugs@gnu.org> with 
> problems
diff mbox series

Patch

diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 8a5967f7b4..cbca1ddeec 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -41,6 +41,8 @@  (define-module (gnu packages libusb)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system python)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages compression)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages java)
@@ -49,6 +51,7 @@  (define-module (gnu packages libusb)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages readline)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages xiph))

@@ -389,6 +392,52 @@  (define-public libu
sbmuxd
 @code{usbmuxd} daemon.")
     (license license:lgpl2.1+)))

+(define-public libirecovery
+  (package
+    (name "libirecovery")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/libimobiledevice"
+                                  "/libirecovery/releases/download/" version
+                                  "/libirecovery-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1d6r9984plynbbiqda8jd7ihnkg6wc4v0iirv3hw4vsv1ahsp86d"))))
+    (build-system gnu-build-system)
+    (native-inputs (list readline
+                         pkg-config
+                         libusb))
+    (home-page "https://libimobiledevice.org/")
+    (synopsis "FIXME")
+    (description "FIXME")
+    (license license:lgpl2.1)))
+
+(define-public idevicerestore
+  (package
+    (name "idevicerestore")
+    (version "1.0.0")
+    (source (origin
+
  (method url-fetch)
+              (uri (string-append "https://github.com/libimobiledevice"
+                                  "/idevicerestore/releases/download/" version
+                                  "/idevicerestore-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "1xrnk1hc9cjcqv8x8l5ankv6f33r5wnpmrwri4pgv5sk6632ww9j"))))
+    (build-system gnu-build-system)
+    (native-inputs (list pkg-config
+                         libusb
+                         libirecovery
+                         libimobiledevice
+                         libzip
+                         curl
+                         zlib))
+    (home-page "https://libimobiledevice.org/")
+    (synopsis "A command-line application to restore firmware files to iOS devices")
+    (description "FIXME")
+    (license license:lgpl3)))
+
 (define-public libimobiledevice