diff mbox series

[bug#57897,1/1] gnu: Add emacs-emprise.

Message ID 20220917232619.921420-1-plattfot@posteo.net
State Accepted
Headers show
Series Add emacs-emprise | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Fredrik Salomonsson Sept. 17, 2022, 11:26 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-emprise): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Sept. 18, 2022, 9:31 a.m. UTC | #1
Hello,

Fredrik Salomonsson <plattfot@posteo.net> writes:

> * gnu/packages/emacs-xyz.scm (emacs-emprise): New variable.

Thank you. Applied with the changes below.

> +   (description "This package provides a set of commands to control media players that
> +supports the MPRIS D-bus protocol from Emacs.  Using Emacs'
> +completing-read framework as the user interface, which integrates well
> +with vertico or selectrum.")

I expounded MPRIS acronym. I also capitalized project names: Completing
Read, Vertico, Selectrum.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d99df6cc69..282bffa274 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2572,6 +2572,29 @@  (define-public emacs-emms-mode-line-cycle
 within a specified width.  It is useful for displaying long track titles.")
     (license license:gpl3+)))
 
+(define-public emacs-emprise
+  (package
+   (name "emacs-emprise")
+   (version "0.3.0")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://git.sr.ht/~plattfot/emprise")
+           (commit (string-append "v" version))))
+     (sha256
+      (base32
+       "0yddvvpjdcgsiwv24jbddkgl5r1lxgz037akjln6z9acx9qrc8px"))
+     (file-name (git-file-name name version))))
+   (build-system emacs-build-system)
+   (home-page "https://sr.ht/~plattfot/emprise/")
+   (synopsis "Control MPRIS supported media players from Emacs")
+   (description "This package provides a set of commands to control media players that
+supports the MPRIS D-bus protocol from Emacs.  Using Emacs'
+completing-read framework as the user interface, which integrates well
+with vertico or selectrum.")
+   (license license:gpl3+)))
+
 
 ;;;
 ;;; Miscellaneous.