diff mbox series

[bug#57892,1/1] gnu: Add emacs-suneater-theme.

Message ID 20220917231201.919836-1-plattfot@posteo.net
State Accepted
Headers show
Series Add emacs-suneater-theme | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Fredrik Salomonsson Sept. 17, 2022, 11:12 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-suneater-theme): New variable.
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou Sept. 18, 2022, 9:30 a.m. UTC | #1
Hello,

Fredrik Salomonsson <plattfot@posteo.net> writes:

> * gnu/packages/emacs-xyz.scm (emacs-suneater-theme): New variable.

Thank you. Applied with the changes below.

> +   (synopsis "Minimalistic dark theme for emacs")

emacs -> Emacs

> +   (description
> +    "A dark, minimalistic emacs theme.  It was based on Sunburst theme but now
> +takes more inspiration from the Nano theme.")

I completed the first sentence: Suneater is a dark, minimalistic Emacs theme.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d99df6cc69..4aca5d569b 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -1348,6 +1348,28 @@  (define-public emacs-theme-sorcery
 Apprentice and Sourcerer.")
       (license license:gpl3+))))
 
+(define-public emacs-suneater-theme
+  (package
+   (name "emacs-suneater-theme")
+   (version "2.0.0")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://git.sr.ht/~plattfot/suneater-theme")
+           (commit version)))
+     (sha256
+      (base32
+       "0nlam8f8ly86y7p2dn10y9ixnm7bhmigsx7si4cjynh6aiyczyds"))
+     (file-name (git-file-name name version))))
+   (build-system emacs-build-system)
+   (home-page "https://git.sr.ht/~plattfot/suneater-theme")
+   (synopsis "Minimalistic dark theme for emacs")
+   (description
+    "A dark, minimalistic emacs theme.  It was based on Sunburst theme but now
+takes more inspiration from the Nano theme.")
+   (license license:gpl3+)))
+
 (define-public emacs-treepy
   (package
     (name "emacs-treepy")