diff mbox series

[bug#57871] ideviceinstaller: new package

Message ID 20220916234058.2039-1-kreyren@rixotstudio.cz
State Accepted
Headers show
Series [bug#57871] ideviceinstaller: new package | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Jacob Hrbek Sept. 16, 2022, 11:41 p.m. UTC
---
 gnu/packages/libusb.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

     (name "libplist")
--
2.37.1

Comments

Jacob Hrbek Sept. 16, 2022, 11:45 p.m. UTC | #1
heads-up: 
<https://github.com/libimobiledevice/ideviceinstaller/issues/147>

On Pá, zář 16 2022 at 23:42:02 +0000, help-debbugs@gnu.org wrote:
> Thank you for filing a new bug report with debbugs.gnu.org.
> 
> This is an automatically generated reply to let you know your message
> has been received.
> 
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
> 
> Your message has been sent to the package maintainer(s):
>  guix-patches@gnu.org <mailto:guix-patches@gnu.org>
> 
> If you wish to submit further information on this problem, please
> send it to 57871@debbugs.gnu.org <mailto:57871@debbugs.gnu.org>.
> 
> Please do not send mail to help-debbugs@gnu.org 
> <mailto:help-debbugs@gnu.org> unless you wish
> to report a problem with the Bug-tracking system.
> 
> --
> 57871: <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=57871>
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org <mailto:help-debbugs@gnu.org> with 
> problems
Jacob Hrbek Sept. 16, 2022, 11:47 p.m. UTC | #2
build log

On Pá, zář 16 2022 at 23:45:45 +0000, Jacob Hrbek 
<kreyren@rixotstudio.cz> wrote:
> heads-up: 
> <https://github.com/libimobiledevice/ideviceinstaller/issues/147>
> 
> On Pá, zář 16 2022 at 23:42:02 +0000, help-debbugs@gnu.org wrote:
>> Thank you for filing a new bug report with debbugs.gnu.org.
>> 
>> This is an automatically generated reply to let you know your message
>> has been received.
>> 
>> Your message is being forwarded to the package maintainers and other
>> interested parties for their attention; they will reply in due 
>> course.
>> 
>> Your message has been sent to the package maintainer(s):
>>  guix-patches@gnu.org <mailto:guix-patches@gnu.org>
>> 
>> If you wish to submit further information on this problem, please
>> send it to 57871@debbugs.gnu.org <mailto:57871@debbugs.gnu.org>.
>> 
>> Please do not send mail to help-debbugs@gnu.org 
>> <mailto:help-debbugs@gnu.org> unless you wish
>> to report a problem with the Bug-tracking system.
>> 
>> --
>> 57871: <https://debbugs.gnu.org/cgi/bugreport.cgi?bug=57871>
>> GNU Bug Tracking System
>> Contact help-debbugs@gnu.org <mailto:help-debbugs@gnu.org> with 
>> problems
Julien Lepiller Sept. 22, 2022, 5:44 a.m. UTC | #3
Pushed to master as 04cad8e29ed85be838921c7fa05f7c5bce94b6d1.

I had to change a few things in the final patch:

First of all, please run "guix lint" on your future submissions, so you
can fix some of these issues beforehand.

I changed the source to look directly for the git repository: the
tarballs at github are not always stable, which might break the
package, and a git source is easier to archive in Software Heritage.

I also wrapped a long line in the description, and removed your
comments about versions, since they are not relevant in Guix. This also
fixes an issue about lonely parenthesis. Note that version constraints
like >= 1.2.3 are not relevant in Guix, since packages are not expected
to ever downgrade.

Then, I added the autotools packages (autoconf, automake and libtool)
for the bootstrap phase to run and generate the configure script.

I moved the runtime dependencies (libimobiledevice and other libraries)
to the inputs instead of the native-inputs. There is no difference
between the two for normal compilation, but when cross-compiling, a
software can only link to inputs and propagated-inputs since they are
for the target platform, whereas native-inputs are for the native
platform (the computer performing the build).

Thanks for the patch!
diff mbox series

Patch

diff --git a/gnu/packages/libusb.scm b/gnu/packages/libusb.scm
index 8a5967f7b4..08206fd87c 100644
--- a/gnu/packages/libusb.scm
+++ b/gnu/packages/libusb.scm
@@ -41,6 +41,7 @@  (define-module (gnu packages libusb)
   #:use-module (guix build-system glib-or-gtk)
   #:use-module (guix build-system python)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages java)
@@ -339,6 +340,28 @@  (define-public python-capablerobot-usbhub
 I2C and SPI devices attached to the USB Hub.")
     (license license:expat)))

+(define-public ideviceinstaller
+  (package
+    (name "ideviceinstaller")
+    (version "1.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/libimobiledevice/ideviceinstaller/rele
ases/download/" version
+                           "/ideviceinstaller-" version ".tar.bz2"))
+       (sha256
+        (base32 "0qrhdhcxd9x901g2zq3znvrfjhy8hcdp17xkm8aq3y7jjzn87f6y"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     (list pkg-config ; >=0.9.0
+           libimobiledevice ; >=1.3.0
+           libzip ; >=0.10
+           ))
+    (home-page "https://libimobiledevice.org/")
+    (synopsis "CLI Tool to manage apps and app archives on iOS devices")
+    (description "This package provides an interface to manage IPA format files and applications for iOS devices, it's written in C")
+    (license license:gpl2)))
+
 (define-public libplist
   (package