diff mbox series

[bug#57744,v3,3/3] gnu: Add shirah.

Message ID 20220915203802.26158-3-matf@disr.it
State Accepted
Headers show
Series [bug#57744,v3,1/3] gnu: Add python-ebooklib. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Sept. 15, 2022, 8:38 p.m. UTC
* gnu/packages/ebook.scm (shirah): New variable.
---
 gnu/packages/ebook.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

Comments

Mathieu Sept. 15, 2022, 8:41 p.m. UTC | #1
Thanks for clarifying! Shirah does not include a license file indeed, but the end of the README clarifies the intent of the author: they say we can use gpl2 or any later version at our convenience. "gpl2+" indeed looks more relevant then since it is listed in one of the source files, as you found.

Hopefully the patchset v3 is okay (I had to reset and restart from scratch, I could not figure out how to rebase v3 into three clean commits if starting from v2).

On 2022-09-15 22:38 M <matf@disr.it> wrote:

> * gnu/packages/ebook.scm (shirah): New variable.
> ---
> gnu/packages/ebook.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>  
> diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
> index 8353012f11..583b3da03b 100644
> --- a/gnu/packages/ebook.scm
> +++ b/gnu/packages/ebook.scm
> @@ -697,3 +697,24 @@ (define-public python-ebooklib
> (description "Ebook library which can handle EPUB2/EPUB3 and Kindle
> format.")
> (license license:agpl3+)))
> +
> +(define-public shirah
> +  (package
> +    (name "shirah")
> +    (version "1.0.0")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "shirah_reader" version))
> +              (sha256
> +               (base32
> +                
> "0j15v435lz68c1mj5clfx5dmfyjc6jvvz2q8hqvv799mb2faj42y"))))
> +    (build-system python-build-system)
> +    (propagated-inputs (list python-beautifulsoup4 python-ebooklib
> +                             python-syllables python-termcolor))
> +    (home-page "https://github.com/hallicopter/shirah-reader")
> +    (synopsis "Terminal ebook reader with an optional RSVP mode")
> +    (description "@command{shirah} is a curses based terminal ebook
> reader that
> +can display ebooks in the usual way or with Rapid Serial Visual
> Presentation, a
> +method to enable speedreading by showing the text word by word at
> configurable
> +speeds.")
> +  (license license:gpl2+)))
> --  
> 2.37.2
>
Christopher Baines Sept. 16, 2022, 10:43 a.m. UTC | #2
Mathieu <matf@disr.it> writes:

> Thanks for clarifying! Shirah does not include a license file indeed,
> but the end of the README clarifies the intent of the author: they say
> we can use gpl2 or any later version at our convenience. "gpl2+"
> indeed looks more relevant then since it is listed in one of the
> source files, as you found.
>
> Hopefully the patchset v3 is okay (I had to reset and restart from
> scratch, I could not figure out how to rebase v3 into three clean
> commits if starting from v2).

Thanks, I've pushed these three patches to master now as
eb9a39c1b75a60fe3946496bb2eee8f32dbf09cd.

Thanks again,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 8353012f11..583b3da03b 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -697,3 +697,24 @@  (define-public python-ebooklib
     (description "Ebook library which can handle EPUB2/EPUB3 and Kindle
 format.")
     (license license:agpl3+)))
+
+(define-public shirah
+  (package
+    (name "shirah")
+    (version "1.0.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "shirah_reader" version))
+              (sha256
+               (base32
+                "0j15v435lz68c1mj5clfx5dmfyjc6jvvz2q8hqvv799mb2faj42y"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-beautifulsoup4 python-ebooklib
+                             python-syllables python-termcolor))
+    (home-page "https://github.com/hallicopter/shirah-reader")
+    (synopsis "Terminal ebook reader with an optional RSVP mode")
+    (description "@command{shirah} is a curses based terminal ebook reader that
+can display ebooks in the usual way or with Rapid Serial Visual Presentation, a
+method to enable speedreading by showing the text word by word at configurable
+speeds.")
+  (license license:gpl2+)))