diff mbox series

[bug#57744,v2,2/3] gnu: Add shirah.

Message ID 20220915195817.4089-2-matf@disr.it
State Accepted
Headers show
Series [bug#57744,v2,1/3] gnu: Add shirah. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Sept. 15, 2022, 7:58 p.m. UTC
* gnu/packages/ebook.scm (shirah): New variable.
---
 gnu/packages/ebook.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

M Sept. 15, 2022, 8:01 p.m. UTC | #1
On 15-09-2022 21:58, M wrote:
> +  (license license:gpl2)))

Going by 
<https://github.com/Hallicopter/shirah-reader/blob/main/shirah_reader/__main__.py>, 
it appears t be gpl2+, not gpl2.
Mathieu Sept. 15, 2022, 8:03 p.m. UTC | #2
Should I not use what they have in the LICENSE at the root of their repository instead?

I messed up my patchset v2, still learning the git send-email workflow, sorry for the clutter messages.

On 2022-09-15 22:01 Maxime Devos <maximedevos@telenet.be> wrote:

>  
>  
> On 15-09-2022 21:58, M wrote:
>> +  (license license:gpl2)))
>  
> Going by
> <https://github.com/Hallicopter/shirah-reader/blob/main/shirah_reader/
> __main__.py>, it appears t be gpl2+, not gpl2.
M Sept. 15, 2022, 8:17 p.m. UTC | #3
On 15-09-2022 22:03, Mathieu wrote:
> Should I not use what they have in the LICENSE at the root of their repository instead?

shirah_reader does not have a LICENSE file, AFAICS.

Even if it did, usually the LICENSE file only contains the license text, 
and not extras like 'which version range'.

Even if there was a LICENSE file that states 'this version only', then 
there is still another file that states 'this version or later', then 
how would we know which one is correct?  Why would LICENSE have 
precedence?  Or why would the source file have precedence?

When such situations happen, we cannot resolve them, only the author can 
clarify matters.

Even if there is only a LICENSE file, then usually it does not specify 
‘this version only’ or ‘this version or later’.  In case of the GPL, we 
then have the following license condition:

‘14. Revised Versions of this License

Each version is given a distinguishing version number.  If the
Program specifies that a certain numbered version of the GNU General
Public License "or any later version" applies to it, you have the
option of following the terms and conditions either of that numbered
version or of any later version published by the Free Software
Foundation.  _If the Program does not specify a version number of the
GNU General Public License, you may choose any version ever published
by the Free Software Foundation._’

I don't consider adding a LICENSE file as ‘specifying a version number’, 
so I'd say that in such cases it's gpl1+ (as the license text needs to 
be distributed along the source code anyway (at least in v2 and v3)). 
(However, I suppose it could be argued that in such cases it's 
implicitly specified that it's ‘version-of-the-LICENSE-file-or-later’. 
Also not a lawyer.  And in such situations, maybe it would be best to 
just ask the author what they meant.)

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index a5a19cb9c0..2ade4f4d7e 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -712,9 +712,9 @@  (define-public shirah
     (propagated-inputs (list python-beautifulsoup4 python-ebooklib
                              python-syllables python-termcolor))
     (home-page "https://github.com/hallicopter/shirah-reader")
-    (synopsis "A curses based terminal ebook reader with optional RSVP mode")
+    (synopsis "Terminal ebook reader with an optional RSVP mode")
     (description "@command{shirah} is a curses based terminal ebook reader that
 can display ebooks in the usual way or with Rapid Serial Visual Presentation, a
 method to enable speedreading by showing the text word by word at configurable
 speeds.")
-  (license license:expat)))
+  (license license:gpl2)))