diff mbox series

[bug#57812] gnu: Add tetzle.

Message ID 20220914193847.24644-1-hendursaga@aol.com
State Accepted
Headers show
Series [bug#57812] gnu: Add tetzle. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hendursaga Sept. 14, 2022, 7:38 p.m. UTC
* gnu/packages/games.scm (tetzle): New public variable.
---
 gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Björn Höfling Sept. 22, 2022, 9:20 a.m. UTC | #1
Hi,

I pushed your patch as:

81ad759ab96a3bfb9801467b7182af6a2d13159d

Thanks.

One note: I merged the patches 57743 and 57812. In the future, please
submit updated patches to the already existing patch/ticket, such that
the discussion is kept on one place.

Björn
Hendursaga Sept. 22, 2022, 2:20 p.m. UTC | #2
> I pushed your patch as:

Thanks!

> One note: I merged the patches 57743 and 57812. In the future, please
> submit updated patches to the already existing patch/ticket

Yes, sorry about that! I was still figuring out git-send-email!

~ Hendursaga
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 60ce0167a6..d22caf4ed9 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -73,6 +73,7 @@ 
 ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
 ;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2684,6 +2685,35 @@  (define-public superstarfighter
     (license (list license:expat         ; game
                    license:silofl1.1)))) ; fonts
 
+(define-public tetzle
+  (package
+    (name "tetzle")
+    (version "2.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://gottcode.org/"
+                                  name
+                                  "/"
+                                  name
+                                  "-"
+                                  version
+                                  "-src.tar.bz2"))
+              (sha256
+               (base32
+                "1m4j4lzqp8fnwmvyglmzcn3vh14ix4hhh52ycmcsjgrsgj1w4p6a"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f)) ; no tests
+    (native-inputs (list qttools))
+    (inputs (list qtbase))
+    (home-page "https://gottcode.org/tetzle/")
+    (synopsis "Jigsaw puzzle game that uses tetrominoes for the pieces")
+    (description
+     "Tetzle is a jigsaw puzzle game that uses tetrominoes for the pieces.  Any image
+can be imported and used to create puzzles with a wide range of sizes.  Games are
+saved automatically, and you can select between currently in progress games.")
+    (license license:gpl3+)))
+
 (define %ufoai-commit "a542a87a891f96b1ab2c44d35b2f6f16859a5019")
 (define %ufoai-revision "0")
 (define %ufoai-version (git-version "2.6.0_dev" %ufoai-revision %ufoai-commit))