diff mbox series

[bug#57791] gnu: Add folders.

Message ID 20220914035626.26126-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#57791] gnu: Add folders. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Sept. 14, 2022, 3:56 a.m. UTC
* gnu/packages/esolangs.scm (folders): New variable.
---
 gnu/packages/esolangs.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

\( Sept. 14, 2022, 6:22 a.m. UTC | #1
Hey, 

On Wed Sep 14, 2022 at 4:56 AM BST, jgart via Guix-patches via wrote:
> +    (description
> +"Implementation of the Folders📂esoteric programming language,
> +a language with no code and just folders.")

I don't think we ought to have that emoji in this description. Also,
remember to format it like this:

> +    (description
> +     "Implementation of the Folders esoteric programming language,
> +a language with no code and just folders.")

(note the indentation on the first line.)

    -- (
Liliana Marie Prikler Sept. 14, 2022, 6:51 p.m. UTC | #2
Am Mittwoch, dem 14.09.2022 um 07:22 +0100 schrieb (:
> 
> > +    (description
> > +     "Implementation of the Folders esoteric programming language,
> > +a language with no code and just folders.")
Thanks for pointing this out, but
1) you missed, that the description was not a sentence (fixed)
2) last time you pointed this out on my package you missed that
   (description "This is my description.")
   is also acceptable.

Pushed with an updated description.  Have fun golfing.
diff mbox series

Patch

diff --git a/gnu/packages/esolangs.scm b/gnu/packages/esolangs.scm
index 81906dac15..96a3ad2064 100644
--- a/gnu/packages/esolangs.scm
+++ b/gnu/packages/esolangs.scm
@@ -3,6 +3,7 @@ 
 ;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
 ;;; Copyright © 2020 Liliana Marie Prikler <liliana.prikler@gmail.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -29,6 +30,7 @@  (define-module (gnu packages esolangs)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system copy)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module ((guix licenses) #:prefix license:)
@@ -99,6 +101,24 @@  (define-public lolcode-lci
       (home-page "http://lolcode.org/")
       (license license:gpl3+))))
 
+(define-public folders
+  (package
+    (name "folders")
+    (version "0.0.8")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "Folders" version))
+        (sha256
+          (base32 "0qh80qx7sjx0zii1hf8fm853d9rcg4rginm6v4gpp0hgn2a4q4gh"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/SinaKhalili/Folders.py")
+    (synopsis "Folders as a programming language")
+    (description
+"Implementation of the Folders📂esoteric programming language,
+a language with no code and just folders.")
+    (license license:expat)))
+
 (define-public shakespeare-spl
   (package
     (name "shakespeare-spl")