diff mbox series

[bug#57784] python-mygnuhealth: New package

Message ID 20220913214448.1976-2-kreyren@rixotstudio.cz
State New
Headers show
Series [bug#57784] python-mygnuhealth: New package | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Jacob Hrbek Sept. 13, 2022, 9:45 p.m. UTC
---
 gnu/packages/mygnuhealth.scm | 61 ++++++++++++++++++++++++++++++++++++
 1 file changed, 61 insertions(+)
 create mode 100644 gnu/packages/mygnuhealth.scm

-- 
2.37.1

Comments

Maxim Cournoyer March 21, 2023, 12:16 p.m. UTC | #1
Hello,

Jacob Hrbek <kreyren@rixotstudio.cz> writes:

> ---
>  gnu/packages/mygnuhealth.scm | 61 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 61 insertions(+)
>  create mode 100644 gnu/packages/mygnuhealth.scm

I applied a different version with
ac6e5d5b8006ddd455a40d32e59f877c75f4ca21.
diff mbox series

Patch

diff --git a/gnu/packages/mygnuhealth.scm b/gnu/packages/mygnuhealth.scm
new file mode 100644
index 0000000000..9d30419d8a
--- /dev/null
+++ b/gnu/packages/mygnuhealth.scm
@@ -0,0 +1,61 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Jacob Hrbek <kreyren@fsfe.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages mygnuhealth)
+  #:use-module (gnu packages python-crypto)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages python-web)
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages qt)
+  #:use-module (gnu packages kde-frameworks)
+  #:use-module (guix packages)
+  #:use-module (guix download)
+  #:use-module (guix build-system python)
+  #:use-module (guix utils)
+  #:use-module ((guix licenses) #:prefix license:))
+
+;;; Commentary:
+;;;
+;;; File defining recipe for building mygnuhealth on GNU Guix
+;;;
+;;; Code:
+
+(define-public python-mygnuhealth
+  (package
+    (name "python-mygnuhealth")
+    (version "1.0.5")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "MyGNUHealth" version))
+              (sha256
+               (base32
+                "1jcrriccqzb4jx7zayhiqmpvi3cvfy3bbf9zr3m83878f94yww8j"))))
+    (build-system python-build-system)
+    (native-inputs
+     (list python-bcrypt python-matplotlib python-requests python-tinydb))
+    (propagated-inputs
+     (list python-pyside-2 kirigami qtbase-5 qtquickcontrols2-5))
+    ;; FIXME-TEST(Krey): Tests are broken, don't know how to fix them
+    (arguments
+     `(#:tests? #f))
+    (home-page "https://www.gnuhealth.org")
+    (synopsis "The GNU Health Personal Health Record")
+    (description "Personal health tracker written in python that integrates with the GNU Health Federation. It's user interface is using Kirigami and QtQuick with tinydb database")
+    (license license:gpl3)))
+
+;;; gnuhealth.scm ends here