diff mbox series

[bug#57770] gnu: Add emacs-app-launcher.

Message ID 20220913140844.23864-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57770] gnu: Add emacs-app-launcher. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Sept. 13, 2022, 2:08 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-app-launcher): New variable.
---
 gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)

Comments

Nicolas Goaziou Sept. 18, 2022, 9:24 a.m. UTC | #1
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-app-launcher): New variable.

Thank you. Applied with the changes below.

> +    (package
> +    (name "emacs-app-launcher")
> +    (version (git-version "0" revision commit))

I used "0.1" as base version since it is specified as such in the
Version keyword.

> +    (description "This package defines the app-launcher-run-app command which

I used @code{app-launcher-run-app} since this is the name of a variable.

> +uses Emacs standard completion to select an application installed on your
> +machine and launch it.")
> +    (license license:gpl3))))

License is actually gpl3+: it includes "or (at your option) any later
version".

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3644d92949..ddae52d8bb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2582,6 +2582,29 @@  (define-public emacs-ace-link
 letter to each link using avy.")
     (license license:gpl3+)))
 
+(define-public emacs-app-launcher
+  (let* ((commit "d5015e394b0a666a8c7c4d4bdf786266e773b145")
+         (revision "0"))
+    (package
+    (name "emacs-app-launcher")
+    (version (git-version "0" revision commit))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/SebastienWae/app-launcher")
+             (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0l97ajy27awydyd4gc6323wyhpm5vm2db6i0lp5gqaxi9fp7jivp"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/SebastienWae/app-launcher")
+    (synopsis "Use Emacs standard completion to launch applications")
+    (description "This package defines the app-launcher-run-app command which
+uses Emacs standard completion to select an application installed on your
+machine and launch it.")
+    (license license:gpl3))))
+
 (define-public emacs-auto-sudoedit
   (package
     (name "emacs-auto-sudoedit")