diff mbox series

[bug#57685,v2,3/3] gnu: vtk: Use system libHaru.

Message ID 20220912192510.420112-4-paul@apatience.com
State Accepted
Headers show
Series gnu: libharu: Update to 2.4.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience Sept. 12, 2022, 7:25 p.m. UTC
* gnu/packages/image-processing.scm (vtk)[snippet]: Delete bundled
libHaru and patch VTK for newer libHaru. Reindent and remove trailing
boolean.
[arguments]: Specify external libHaru in configure flags.
[inputs]: Add libharu.
---
 gnu/packages/image-processing.scm | 22 ++++++++++++++--------
 1 file changed, 14 insertions(+), 8 deletions(-)

--
2.37.3
diff mbox series

Patch

diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 0225f72651..4600c71ce0 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -324,14 +324,18 @@  (define-public vtk
               (snippet
                '(begin
                   (for-each
-                    (lambda (dir)
-                      (delete-file-recursively
-                        (string-append "ThirdParty/" dir "/vtk" dir)))
-                    ;; pugixml depended upon unconditionally
-                    '("doubleconversion" "eigen" "expat" "freetype" "gl2ps"
-                      "glew" "hdf5" "jpeg" "jsoncpp" "libproj" "libxml2" "lz4"
-                      "netcdf" "ogg" "png" "sqlite" "theora" "tiff" "zlib"))
-                  #t))))
+                   (lambda (dir)
+                     (delete-file-recursively
+                      (string-append "ThirdParty/" dir "/vtk" dir)))
+                   ;; pugixml depended upon unconditionally
+                   '("doubleconversion" "eigen" "expat" "freetype" "gl2ps"
+                     "glew" "hdf5" "jpeg" "jsoncpp" "libharu" "libproj"
+                     "libxml2" "lz4" "netcdf" "ogg" "png" "sqlite" "theora"
+                     "tiff" "zlib"))
+                  (substitute* "IO/ExportPDF/vtkPDFContextDevice2D.cxx"
+                    (("\\bHPDF_UINT16 (noPen|dash|dot|denseDot|dashDot|dashDotDot)\\b"
+                      _ var)
+                     (string-append "HPDF_REAL " var)))))))
     (properties `((release-monitoring-url . "https://vtk.org/download/")))
     (build-system cmake-build-system)
     (arguments
@@ -348,6 +352,7 @@  (define-public vtk
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_hdf5=ON"
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_jpeg=ON"
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_jsoncpp=ON"
+                           "-DVTK_MODULE_USE_EXTERNAL_VTK_libharu=ON"
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_libproj=ON"
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_libxml2=ON"
                            "-DVTK_MODULE_USE_EXTERNAL_VTK_lz4=ON"
@@ -381,6 +386,7 @@  (define-public vtk
            glew
            glu
            hdf5
+           libharu
            libjpeg-turbo
            jsoncpp
            libtheora