diff mbox series

[bug#57685,v2,1/3] gnu: libharu: Update to 2.4.2.

Message ID 20220912192510.420112-2-paul@apatience.com
State Accepted
Headers show
Series gnu: libharu: Update to 2.4.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience Sept. 12, 2022, 7:25 p.m. UTC
* gnu/packages/pdf.scm (libharu): Update to 2.4.2.
[build-system]: Switch to cmake-build-system.
[arguments]: Remove #:configure-flags, add #:tests? and #:phases.
[inputs]: Sort them.
[native-inputs]: Remove.
---
 gnu/packages/pdf.scm | 44 +++++++++++++++++++++++---------------------
 1 file changed, 23 insertions(+), 21 deletions(-)

--
2.37.3
diff mbox series

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 14f75d9ef9..c5076fbe45 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -363,29 +364,30 @@  (define-public python-poppler-qt5
 (define-public libharu
   (package
    (name "libharu")
-   (version "2.3.0")
-   (source (origin
-             (method git-fetch)
-             (uri (git-reference
-                   (url "https://github.com/libharu/libharu")
-                   (commit (string-append
-                            "RELEASE_"
-                            (string-join (string-split version #\.) "_")))))
-             (file-name (git-file-name name version))
-             (sha256
-              (base32
-               "15s9hswnl3qqi7yh29jyrg0hma2n99haxznvcywmsp8kjqlyg75q"))))
-   (build-system gnu-build-system)
+   (version "2.4.2")
+   (source
+    (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/libharu/libharu")
+            (commit (string-append "v" version))))
+      (file-name (git-file-name name version))
+      (sha256
+       (base32 "1jwzqvv81zf5f7zssyixhyjirlp9ddwkbaabd177syb1bxljlsdc"))))
+   (build-system cmake-build-system)
    (arguments
-    `(#:configure-flags
-      (list (string-append "--with-zlib="
-                           (assoc-ref %build-inputs "zlib"))
-            (string-append "--with-png="
-                           (assoc-ref %build-inputs "libpng")))))
+    (list #:tests? #f                   ; No tests
+          #:phases
+          #~(modify-phases %standard-phases
+              (add-after 'unpack 'patch-cmake
+                (lambda _
+                  (substitute* "CMakeLists.txt"
+                    (("^install\\(FILES (README\\.md CHANGES) INSTALL DESTINATION .*\\)"
+                      _ files)
+                     (format #f "install(FILES ~a DESTINATION ~a/share/doc/~a-~a)"
+                             files #$output #$name #$version))))))))
    (inputs
-    (list zlib libpng))
-   (native-inputs
-    (list autoconf automake libtool))
+    (list libpng zlib))
    (home-page "http://libharu.org/")
    (synopsis "Library for generating PDF files")
    (description