diff mbox series

[bug#57745] gnu: Add emacs-ednc.

Message ID 20220912064949.9994-1-ngraves@ngraves.fr
State Accepted
Headers show
Series [bug#57745] gnu: Add emacs-ednc. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Nicolas Graves Sept. 12, 2022, 6:49 a.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ednc): New variable.
---
 gnu/packages/emacs-xyz.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Nicolas Goaziou Sept. 13, 2022, 12:51 p.m. UTC | #1
Hello,

Nicolas Graves via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ednc): New variable.

Applied with the changes below. Thank you.

> +    (version "20220404.2105")

I set the base version to "0.1" as specified in "ednc.el" headers.

> +    (description
> +     "The Emacs Desktop Notification Center (EDNC) is an Emacs package written in pure
> +Lisp that implements a Desktop Notifications service according to the
> +freedesktop.org specification.  EDNC aspires to be a small, but flexible drop-in
> +replacement of standalone daemons like Dunst.  A global minor mode `ednc-mode'
> +tracks active notifications, which users can access by calling the function
> +`ednc-notifications'.  They are also free to add their own functions to the
> +(abnormal) hook `ednc-notification-amendment-functions' to amend arbitrary data
> +and to the (abnormal) hook `ednc-notification-presentation-functions' to present
> +notifications as they see fit.  To be useful out of the box, default hooks
> +record all notifications in an interactive log buffer `*ednc-log*'.")

I removed the last part of the description, which belongs to the package
documentation instead.

> +    (license license:gpl3)))

I changed the license to gpl3+ as specified in "ednc.el" headers.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ea5953ca4f..624a5ee030 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -30199,6 +30199,34 @@  (define-public emacs-edn
 data format @code{edn}.  See @url{https://github.com/edn-format/edn}.")
       (license license:gpl3+))))
 
+(define-public emacs-ednc
+  (package
+    (name "emacs-ednc")
+    (version "20220404.2105")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/sinic/ednc.git")
+             (commit "940a4adbbeb3b6b1a72270a814d52770dd89a997")))
+       (sha256
+        (base32 "1gsx2qgv5xm9r0i0axd4hf31g2rq2m4a1hvnif48g4xb0llss73c"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/sinic/ednc")
+    (synopsis "Emacs Desktop Notification Center")
+    (description
+     "The Emacs Desktop Notification Center (EDNC) is an Emacs package written in pure
+Lisp that implements a Desktop Notifications service according to the
+freedesktop.org specification.  EDNC aspires to be a small, but flexible drop-in
+replacement of standalone daemons like Dunst.  A global minor mode `ednc-mode'
+tracks active notifications, which users can access by calling the function
+`ednc-notifications'.  They are also free to add their own functions to the
+(abnormal) hook `ednc-notification-amendment-functions' to amend arbitrary data
+and to the (abnormal) hook `ednc-notification-presentation-functions' to present
+notifications as they see fit.  To be useful out of the box, default hooks
+record all notifications in an interactive log buffer `*ednc-log*'.")
+    (license license:gpl3)))
+
 (define-public emacs-helm-clojuredocs
   (let ((commit "5a7f0f2cb401be0b09e73262a1c18265ab9a3cea"))
     (package