diff mbox series

[bug#57743] gnu: Add tetzle.

Message ID 20220911214712.59471-1-hendursaga@aol.com
State Accepted
Headers show
Series [bug#57743] gnu: Add tetzle. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hendursaga Sept. 11, 2022, 9:47 p.m. UTC
* gnu/packages/games.scm (tetzle): New public variable.
---
 gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

Comments

Christopher Baines Sept. 14, 2022, 8:15 a.m. UTC | #1
Hendursaga via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/games.scm (tetzle): New public variable.
> ---
>  gnu/packages/games.scm | 30 ++++++++++++++++++++++++++++++
>  1 file changed, 30 insertions(+)

Hey Hendursaga,

Thanks for the patch. I've made one comment below.

> diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
> index 2c7f892f19..a5179b86fa 100644
> --- a/gnu/packages/games.scm
> +++ b/gnu/packages/games.scm
> @@ -73,6 +73,7 @@
>  ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
>  ;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
>  ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
> +;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -11169,3 +11170,32 @@ (define-public freerct
>  Should they go unwise, a theme park plunge into chaos with vandalizing guests
>  and unsafe rides.  Which path will you take?")
>      (license license:gpl2)))
> +
> +(define-public tetzle
> +  (package
> +    (name "tetzle")
> +    (version "2.2.1")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (string-append "https://gottcode.org/"
> +                                  name
> +                                  "/"
> +                                  name
> +                                  "-"
> +                                  version
> +                                  "-src.tar.bz2"))
> +              (sha256
> +               (base32
> +                "1m4j4lzqp8fnwmvyglmzcn3vh14ix4hhh52ycmcsjgrsgj1w4p6a"))))
> +    (build-system cmake-build-system)
> +    (arguments
> +     `(#:tests? #f))

Why are the tests disabled? It's good to run the tests if that's
possible. If it's not possible, it's good to add a comment describing
why the tests can't be run.

> +    (native-inputs (list qttools))
> +    (inputs (list qtbase))
> +    (home-page "https://gottcode.org/tetzle/")
> +    (synopsis "Jigsaw puzzle game that uses tetrominoes for the pieces")
> +    (description
> +     "Tetzle is a jigsaw puzzle game that uses tetrominoes for the pieces.  Any image
> +can be imported and used to create puzzles with a wide range of sizes.  Games are
> +saved automatically, and you can select between currently in progress games.")
> +    (license license:gpl3+)))
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 2c7f892f19..a5179b86fa 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -73,6 +73,7 @@ 
 ;;; Copyright © 2022 zamfofex <zamfofex@twdb.moe>
 ;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022 Hendursaga <hendursaga@aol.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -11169,3 +11170,32 @@  (define-public freerct
 Should they go unwise, a theme park plunge into chaos with vandalizing guests
 and unsafe rides.  Which path will you take?")
     (license license:gpl2)))
+
+(define-public tetzle
+  (package
+    (name "tetzle")
+    (version "2.2.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://gottcode.org/"
+                                  name
+                                  "/"
+                                  name
+                                  "-"
+                                  version
+                                  "-src.tar.bz2"))
+              (sha256
+               (base32
+                "1m4j4lzqp8fnwmvyglmzcn3vh14ix4hhh52ycmcsjgrsgj1w4p6a"))))
+    (build-system cmake-build-system)
+    (arguments
+     `(#:tests? #f))
+    (native-inputs (list qttools))
+    (inputs (list qtbase))
+    (home-page "https://gottcode.org/tetzle/")
+    (synopsis "Jigsaw puzzle game that uses tetrominoes for the pieces")
+    (description
+     "Tetzle is a jigsaw puzzle game that uses tetrominoes for the pieces.  Any image
+can be imported and used to create puzzles with a wide range of sizes.  Games are
+saved automatically, and you can select between currently in progress games.")
+    (license license:gpl3+)))