diff mbox series

[bug#57021,v3] gnu: Add nmail.

Message ID 20220911214146.9920-1-matf@disr.it
State New
Headers show
Series [bug#57021,v3] gnu: Add nmail. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Sept. 11, 2022, 9:41 p.m. UTC
* gnu/packages/mail.scm (nmail): New variable.
---
 gnu/packages/mail.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

Comments

Mathieu Sept. 11, 2022, 9:46 p.m. UTC | #1
I am sending a v3 patch even though a new version of nmail has not been released upstream, but will try to update it when a new version is available.

As far as I understand, the imports are no longer necessary with master, I think all required modules are already in mail.scm now, and properly sorted in alphabetic order (so that should not be necessary either). Please let me know if I got something wrong.
Mathieu Sept. 11, 2022, 9:56 p.m. UTC | #2
And I'll be sending a v4 very soon because I see that the v3 above doesn't take into account the latest changesi from the v2, I reused an outdated version of the patch. My bad.
diff mbox series

Patch

diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 65d8060862..0526ccb521 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -50,6 +50,7 @@ 
 ;;; Copyright © 2022 Guillaume Le Vaillant <glv@posteo.net>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
 ;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -405,6 +406,42 @@  (define-public mailutils
      ;; Libraries are under LGPLv3+, and programs under GPLv3+.
      (list license:gpl3+ license:lgpl3+))))
 
+(define-public nmail
+  (package
+    (name "nmail")
+    (version "3.74")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/d99kris/nmail/")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "07lkl5syx3l37dhsl41nhmjknhxqgmvwc4il4gygsnr333qk75c9"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:phases #~(modify-phases %standard-phases
+                        (replace 'check
+                          (lambda*
+                              (#:key tests? #:allow-other-keys)
+                              (when tests? (invoke "ctest" "--output-on-failure")))))))
+    (inputs (list libetpan
+                  xapian
+                  sqlite
+                  cyrus-sasl
+                  ncurses
+                  openssl
+                  file
+                  (list util-linux "lib")))
+    (native-inputs (list pkg-config))
+    (home-page "https://github.com/d99kris/nmail")
+    (synopsis "Terminal-based email client")
+    (description
+     "@command{nmail} is a terminal-based email client with a
+@code{ncurses} user interface similar to @code{alpine} and @code{pine}.")
+    (license license:expat)))
+
 (define-public go-gitlab.com-shackra-goimapnotify
   (package
     (name "go-gitlab.com-shackra-goimapnotify")