diff mbox series

[bug#57734,1/1] gnu: Add rot8.

Message ID 20220911173726.14214-2-matf@disr.it
State Accepted
Headers show
Series [bug#57734,1/1] gnu: Add rot8. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mathieu Sept. 11, 2022, 5:37 p.m. UTC
* gnu/packages/rust-apps.scm (rot8): New variable.
---
 gnu/packages/rust-apps.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Mathieu Sept. 11, 2022, 5:58 p.m. UTC | #1
I just found https://issues.guix.gnu.org/49703 too, I should have looked better. Can those be merged?

Also, I realized that I had another modified file when I sent the patch (gnu/packages/monitoring.scm) and I did not notice that both patches were sent in the same issue until I saw my emails. How could I fix this?
\( Sept. 11, 2022, 6:50 p.m. UTC | #2
On Sun Sep 11, 2022 at 6:58 PM BST, M wrote:
> I just found https://issues.guix.gnu.org/49703 too, I should have looked better. Can those be merged?

Your one looks better, to be honest. It's fine if there's an abandoned older
version of a package; that's the case with my aerc patchset.

> Also, I realized that I had another modified file when I sent the patch (gnu/packages/monitoring.scm) and I did not notice that both patches were sent in the same issue until I saw my emails. How could I fix this?

There's no way you can fix it, afaik. It doesn't matter, really.

    -- (
Ludovic Courtès Sept. 24, 2022, 2:15 p.m. UTC | #3
M <matf@disr.it> skribis:

> * gnu/packages/rust-apps.scm (rot8): New variable.

Applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index b89eff4eb0..8e7c4a0ed5 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -18,6 +18,7 @@ 
 ;;; Copyright © 2022 Aleksandr Vityazev <avityazev@posteo.org>
 ;;; Copyright © 2022 Gabriel Arazas <foo.dogsquared@gmail.com>
 ;;; Copyright © 2022 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -768,6 +769,31 @@  (define-public ripgrep
 gitignore rules.")
     (license (list license:unlicense license:expat))))
 
+(define-public rot8
+  (package
+    (name "rot8")
+    (version "0.1.4")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "rot8" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1m5kzpqq9pgc19lbnh20iaq654lzlmc1m5fc9f73w2vpwqdiw1qf"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-clap" ,rust-clap-2)
+                       ("rust-glob" ,rust-glob-0.3)
+                       ("rust-regex" ,rust-regex-1)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-json" ,rust-serde-json-1))))
+    (home-page "https://github.com/efernau/rot8/")
+    (synopsis "Automatic display rotation using built-in accelerometer")
+    (description "@command{rot8} is a daemon that automates rotating screen and
+associated input devices using the built-in accelerometer; handy for convertible
+touchscreen devices.")
+    (license license:expat)))
+                
 (define-public git-interactive-rebase-tool
   (package
     (name "git-interactive-rebase-tool")