diff mbox series

[bug#57716] gnu: python-qrcode: Update to 7.3.1.

Message ID 20220910122942.7989-1-felgru@posteo.net
State Accepted
Headers show
Series [bug#57716] gnu: python-qrcode: Update to 7.3.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Sept. 10, 2022, 12:29 p.m. UTC
* gnu/packages/python-xyz.scm (python-qrcode): Update to 7.3.1.
[propagated-inputs]: Remove python-six.
---
 gnu/packages/python-xyz.scm | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

Comments

Mathieu Othacehe Sept. 11, 2022, 2 p.m. UTC | #1
> * gnu/packages/python-xyz.scm (python-qrcode): Update to 7.3.1.
> [propagated-inputs]: Remove python-six.

Applied, thanks!

Mathieu
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 86fed87f26..a02a7c2122 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -18825,21 +18825,20 @@  from the header, as well as section details and data available.")
 (define-public python-qrcode
   (package
     (name "python-qrcode")
-    (version "6.1")
+    (version "7.3.1")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "qrcode" version))
        (sha256
-        (base32 "0sa3n298b9jpz6zn0birnjii3mg9sihjq28n9nzjlzv09y2m6ljh"))))
+        (base32 "0y35jlwfvkgn9341lzshyaqgpp61vysjh107vhdd96ya83r6ynip"))))
     (build-system python-build-system)
     (arguments
      ;; FIXME: Tests require packaging 'pymaging'.
      '(#:tests? #f))
     (propagated-inputs
      (list python-lxml ; for SVG output
-           python-pillow ; for PNG output
-           python-six))
+           python-pillow)) ; for PNG output
     (home-page "https://github.com/lincolnloop/python-qrcode")
     (synopsis "QR Code image generator")
     (description "This package provides a pure Python QR Code generator