diff mbox series

[bug#57688,v5] gnu: Add wiggle.

Message ID 20220909140612.1910-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#57688,v5] gnu: Add wiggle. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Sept. 9, 2022, 2:06 p.m. UTC
* gnu/packages/patchutils.scm (wiggle): New variable.

no probs, here's v5
---
 gnu/packages/patchutils.scm | 45 +++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

Comments

\( Sept. 9, 2022, 11:03 p.m. UTC | #1
Hello! :D

On Fri Sep 9, 2022 at 3:06 PM BST, jgart via Guix-patches via wrote:
> +(define-public wiggle
> +    (package
     ^^
Unnecessary indentation here.

> +      (name "wiggle")
> +      (version "1.3")
> +      (source
> +       (origin
         ^^^^^^^^
Change to `(source (origin'.

> +         (method git-fetch)
> +         (uri
> +          (git-reference
            ^^^^^^^^^^^^^^^
Change to `(uri (git-reference'.

> +      (inputs
> +        (list ncurses))
         ^^^^^^^
Change to `(inputs (list ...))'.

> +      (arguments
> +        (list #:make-flags
          ^
This extra indentation isn't the norm.

> +              #~(list "-I. -O3"
> +                      (string-append "CC=" #$(cc-for-target))
> +                      "INSTALL=\"install\""
> +                      "STRIP=-s"
> +                      (string-append "BINDIR=" #$output "/bin")
> +                      (string-append "MANDIR=" #$output "/share/man")
> +                      (string-append "CC=" #$(cc-for-target))
                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Duplicate `CC' definition.

> +                      (string-append "PREFIX=" #$output))
> +               #:phases
> +               #~(modify-phases %standard-phases
> +                   (delete 'configure)
> +                   (replace 'check
> +                     (lambda* (#:key inputs ouputs tests? #:allow-other-keys)
                                        ^^^^^^^^^^^^^
These two are unnecessary, and the latter has a typo anyway.

> +      (home-page "http://neil.brown.name/wiggle/")
> +      (synopsis "Tool for applying patches with conflicts")
> +      (description
> +"@code{wiggle} attempts to apply patches to a target file even if the
   ^^^^^^^^
Add indentation here.

    -- (
jgart Sept. 10, 2022, 1:15 a.m. UTC | #2
On Sat, 10 Sep 2022 00:03:02 +0100 "(" <paren@disroot.org> wrote:
> Hello! :D

hiya paren ;#~ ;#$ ;()

> Duplicate `CC' definition.
> These two are unnecessary, and the latter has a typo anyway.

I edited these by hand and let `guix style` take care of the rest

thanks for the review!

look out for v6,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index fdbcb8e1e1..e87d0a2e86 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +22,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages patchutils)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix licenses)
@@ -40,6 +42,7 @@  (define-module (gnu packages patchutils)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages groff)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages less)
   #:use-module (gnu packages mail)
@@ -441,6 +444,48 @@  (define pythonpath
     (home-page "http://jk.ozlabs.org/projects/patchwork/")
     (license gpl2+)))
 
+(define-public wiggle
+    (package
+      (name "wiggle")
+      (version "1.3")
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/neilbrown/wiggle")
+           (commit (string-append "v" version))))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "18ilzr9sbal1j8p1d94ilm1j5blac5cngvcvjpdmgmpw6diy2ldf"))))
+      (build-system gnu-build-system)
+      (native-inputs (list groff))
+      (inputs
+        (list ncurses))
+      (arguments
+        (list #:make-flags
+              #~(list "-I. -O3"
+                      (string-append "CC=" #$(cc-for-target))
+                      "INSTALL=\"install\""
+                      "STRIP=-s"
+                      (string-append "BINDIR=" #$output "/bin")
+                      (string-append "MANDIR=" #$output "/share/man")
+                      (string-append "CC=" #$(cc-for-target))
+                      (string-append "PREFIX=" #$output))
+               #:phases
+               #~(modify-phases %standard-phases
+                   (delete 'configure)
+                   (replace 'check
+                     (lambda* (#:key inputs ouputs tests? #:allow-other-keys)
+                       (when tests?
+                         (invoke "./dotest")))))))
+      (home-page "http://neil.brown.name/wiggle/")
+      (synopsis "Tool for applying patches with conflicts")
+      (description
+"@code{wiggle} attempts to apply patches to a target file even if the
+patches do not match perfectly.")
+      (license gpl2+)))
+
 (define-public pwclient
   (package
     (name "pwclient")