diff mbox series

[bug#57688,v4] gnu: Add wiggle.

Message ID 20220909041458.3972-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#57688,v4] gnu: Add wiggle. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Sept. 9, 2022, 4:14 a.m. UTC
* gnu/packages/patchutils.scm (wiggle): New variable.

Hi again Maxime,

Here's v4. Forgot to add the gexps everywhere.

#$all best,

jgart

---
 gnu/packages/patchutils.scm | 45 +++++++++++++++++++++++++++++++++++++
 1 file changed, 45 insertions(+)

Comments

M Sept. 9, 2022, 12:35 p.m. UTC | #1
On 09-09-2022 06:14, jgart wrote:
> +      (arguments
> +        (list #:make-flags
> +              #~(list "-I. -O3"
> +                      (string-append "CC=" #$(cc-for-target))
> +                      "INSTALL=\"install\""
> +                      "STRIP=-s"
> +                      (string-append "BINDIR=" #$output "/bin")
> +                      (string-append "MANDIR=" #$output "/share/man")
> +                      (string-append "CC=" #$(cc-for-target))
> +                      (string-append "PREFIX=" #$output))
> +               #:phases
> +               '(modify-phases %standard-phases

Nitpick: using G-exp for #:make-flags but not #:phases is inconsistent, 
though that's something a committer could adjust without any trouble.

> +                  (delete 'configure)
> +                  (replace 'check
> +                    (lambda* (#:key inputs ouputs tests? #:allow-other-keys)
> +                      (when tests?
> +                        (invoke "./dotest")))))))

That's what I had in mind, thanks.  For completeness, ideally someone 
would check the sources for malware, but otherwise LGTM.

Greetings,
Maxime.
diff mbox series

Patch

diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index fdbcb8e1e1..86e052a18f 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -4,6 +4,7 @@ 
 ;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
 ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -21,6 +22,7 @@ 
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages patchutils)
+  #:use-module (guix gexp)
   #:use-module (guix utils)
   #:use-module (guix packages)
   #:use-module (guix licenses)
@@ -40,6 +42,7 @@  (define-module (gnu packages patchutils)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
+  #:use-module (gnu packages groff)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages less)
   #:use-module (gnu packages mail)
@@ -441,6 +444,48 @@  (define pythonpath
     (home-page "http://jk.ozlabs.org/projects/patchwork/")
     (license gpl2+)))
 
+(define-public wiggle
+    (package
+      (name "wiggle")
+      (version "1.3")
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/neilbrown/wiggle")
+           (commit (string-append "v" version))))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "18ilzr9sbal1j8p1d94ilm1j5blac5cngvcvjpdmgmpw6diy2ldf"))))
+      (build-system gnu-build-system)
+      (native-inputs (list groff))
+      (inputs
+        (list ncurses))
+      (arguments
+        (list #:make-flags
+              #~(list "-I. -O3"
+                      (string-append "CC=" #$(cc-for-target))
+                      "INSTALL=\"install\""
+                      "STRIP=-s"
+                      (string-append "BINDIR=" #$output "/bin")
+                      (string-append "MANDIR=" #$output "/share/man")
+                      (string-append "CC=" #$(cc-for-target))
+                      (string-append "PREFIX=" #$output))
+               #:phases
+               '(modify-phases %standard-phases
+                  (delete 'configure)
+                  (replace 'check
+                    (lambda* (#:key inputs ouputs tests? #:allow-other-keys)
+                      (when tests?
+                        (invoke "./dotest")))))))
+      (home-page "http://neil.brown.name/wiggle/")
+      (synopsis "Tool for applying patches with conflicts")
+      (description
+"@code{wiggle} attempts to apply patches to a target file even if the
+patches do not match perfectly.")
+      (license gpl2+)))
+
 (define-public pwclient
   (package
     (name "pwclient")