diff mbox series

[bug#57687,7/9] gnu: openorienteering-mapper: Add curl dependency.

Message ID 20220908201438.89973-7-felgru@posteo.net
State Accepted
Headers show
Series Update proj to 9.0.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Felix Gruber Sept. 8, 2022, 8:14 p.m. UTC
* gnu/packages/geo.scm (openorienteering-mapper)[inputs]: Add curl.
---
 gnu/packages/geo.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

M Sept. 8, 2022, 9:12 p.m. UTC | #1
On 08-09-2022 22:14, Felix Gruber wrote:
> * gnu/packages/geo.scm (openorienteering-mapper)[inputs]: Add curl.
> ---
>   gnu/packages/geo.scm | 1 +
>   1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
> index f27c97477d..c0ac44a81b 100644
> --- a/gnu/packages/geo.scm
> +++ b/gnu/packages/geo.scm
> @@ -2209,6 +2209,7 @@ track your position right from your laptop.")
>       (inputs
>        `(("clipper" ,clipper)
>          ("cups" ,cups)
> +       ("curl" ,curl)
>          ("gdal" ,gdal)
>          ("proj" ,proj)
>          ("qtbase" ,qtbase-5)

Why?

According to "grep -rF 
/gnu/store/m06nhjir7vxm2kq88dlm7cvpxcyhilzr-openorienteering-mapper-0.9.5-checkout", 
it's curl is not actually used by openorienteering-mapper (except for 
"superbuild-licensing.cmake" and the CI, but I don't think we actually 
use those in Guix). What's the point of adding 'curl' here?

Greetings,
Maxime
M Sept. 8, 2022, 9:13 p.m. UTC | #2
On 08-09-2022 22:14, Felix Gruber wrote:
> * gnu/packages/geo.scm (openorienteering-mapper)[inputs]: Add curl.
> ---
>   gnu/packages/geo.scm | 1 +
>   1 file changed, 1 insertion(+)
>
> diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
> index f27c97477d..c0ac44a81b 100644
> --- a/gnu/packages/geo.scm
> +++ b/gnu/packages/geo.scm
> @@ -2209,6 +2209,7 @@ track your position right from your laptop.")
>       (inputs
>        `(("clipper" ,clipper)
>          ("cups" ,cups)
> +       ("curl" ,curl)
>          ("gdal" ,gdal)
>          ("proj" ,proj)
>          ("qtbase" ,qtbase-5)
Nevermind my comment about curl, I've now seen the cover letter ...
diff mbox series

Patch

diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index f27c97477d..c0ac44a81b 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2209,6 +2209,7 @@  track your position right from your laptop.")
     (inputs
      `(("clipper" ,clipper)
        ("cups" ,cups)
+       ("curl" ,curl)
        ("gdal" ,gdal)
        ("proj" ,proj)
        ("qtbase" ,qtbase-5)