diff mbox series

[bug#57685] gnu: libharu: Update to 2.4.1.

Message ID 20220908195104.346056-1-paul@apatience.com
State Accepted
Headers show
Series [bug#57685] gnu: libharu: Update to 2.4.1. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Paul A. Patience Sept. 8, 2022, 7:51 p.m. UTC
* gnu/packages/pdf.scm (libharu): Update to 2.4.1.
[build-system]: Switch to cmake-build-system.
[arguments]: Remove #:configure-flags, add #:tests? and #:phases.
[inputs]: Sort them.
[native-inputs]: Remove.
---
 gnu/packages/pdf.scm | 44 +++++++++++++++++++++++---------------------
 1 file changed, 23 insertions(+), 21 deletions(-)

--
2.37.3

Comments

Christopher Baines Sept. 10, 2022, 9:55 a.m. UTC | #1
"Paul A. Patience" <paul@apatience.com> writes:

> * gnu/packages/pdf.scm (libharu): Update to 2.4.1.
> [build-system]: Switch to cmake-build-system.
> [arguments]: Remove #:configure-flags, add #:tests? and #:phases.
> [inputs]: Sort them.
> [native-inputs]: Remove.
> ---
>  gnu/packages/pdf.scm | 44 +++++++++++++++++++++++---------------------
>  1 file changed, 23 insertions(+), 21 deletions(-)

This looks to break the build for the saga package. Do you see it fail
to build locally with this change?

Thanks,

Chris
Christopher Baines Sept. 17, 2022, 5:20 p.m. UTC | #2
"Paul A. Patience" <paul@apatience.com> writes:

> The issue causing the saga build to fail was fixed in libHaru 2.4.2, so I
> updated it to that version.
> (I had tested the build of emboss, which also depends on libHaru, but not that
> of saga; I should have.)
>
> saga still needed a patch, and VTK too, because the 2.4.0 update of libHaru
> contained several breaking changes.
>
> Paul A. Patience (3):
>   gnu: libharu: Update to 2.4.2.
>   gnu: saga: Fix build with newer libHaru.
>   gnu: vtk: Use system libHaru.
>
>  gnu/packages/geo.scm              |  9 ++++++-
>  gnu/packages/image-processing.scm | 22 ++++++++++------
>  gnu/packages/pdf.scm              | 44 ++++++++++++++++---------------
>  3 files changed, 45 insertions(+), 30 deletions(-)

Thanks, these changes generally look good to me, and seem to update/fix
things, so I've gone ahead and pushed them to master as
c967d1153cae419e4acbe0dbed8f558d95ced0e3.

Thanks again,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 14f75d9ef9..d449d36818 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
 ;;; Copyright © 2020, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -363,29 +364,30 @@  (define-public python-poppler-qt5
 (define-public libharu
   (package
    (name "libharu")
-   (version "2.3.0")
-   (source (origin
-             (method git-fetch)
-             (uri (git-reference
-                   (url "https://github.com/libharu/libharu")
-                   (commit (string-append
-                            "RELEASE_"
-                            (string-join (string-split version #\.) "_")))))
-             (file-name (git-file-name name version))
-             (sha256
-              (base32
-               "15s9hswnl3qqi7yh29jyrg0hma2n99haxznvcywmsp8kjqlyg75q"))))
-   (build-system gnu-build-system)
+   (version "2.4.1")
+   (source
+    (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://github.com/libharu/libharu")
+            (commit (string-append "v" version))))
+      (file-name (git-file-name name version))
+      (sha256
+       (base32 "0371ba8ffqczdw7xnkx6pkjdbgw8s2yvqp7b8j0n2ky9cx4ga8v4"))))
+   (build-system cmake-build-system)
    (arguments
-    `(#:configure-flags
-      (list (string-append "--with-zlib="
-                           (assoc-ref %build-inputs "zlib"))
-            (string-append "--with-png="
-                           (assoc-ref %build-inputs "libpng")))))
+    (list #:tests? #f                   ; No tests
+          #:phases
+          #~(modify-phases %standard-phases
+              (add-after 'unpack 'patch-cmake
+                (lambda _
+                  (substitute* "CMakeLists.txt"
+                    (("^install\\(FILES (README\\.md CHANGES) INSTALL DESTINATION .*\\)"
+                      _ files)
+                     (format #f "install(FILES ~a DESTINATION ~a/share/doc/~a-~a)"
+                             files #$output #$name #$version))))))))
    (inputs
-    (list zlib libpng))
-   (native-inputs
-    (list autoconf automake libtool))
+    (list libpng zlib))
    (home-page "http://libharu.org/")
    (synopsis "Library for generating PDF files")
    (description