diff mbox series

[bug#57628] gnunet-scheme: Unbundle config.rpath.

Message ID 20220906173023.14658-1-maximedevos@telenet.be
State Accepted
Headers show
Series [bug#57628] gnunet-scheme: Unbundle config.rpath. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

M Sept. 6, 2022, 5:30 p.m. UTC
* gnu/packages/gnunet.scm (gnunet-scheme)[origin]{snippet}: New snippet.
---
 gnu/packages/gnunet.scm | 8 +++++++-
 1 file changed, 7 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 1288d8d18c..b477fee537 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -362,7 +362,13 @@  (define-public gnunet-scheme
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0kvqbqijfyp3fhsqjyzwd7b3cm5khwv557wq196mv6rx47aaivgd"))))
+                "0kvqbqijfyp3fhsqjyzwd7b3cm5khwv557wq196mv6rx47aaivgd"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; Unbundle dependencies.  TODO: build-aux/test-driver.scm
+               ;; is bundled too, but it's not yet automatically copied by
+               ;; autoreconf -i.
+               #~(delete-file "build-aux/config.rpath"))))
     (build-system gnu-build-system)
     (arguments
      (list #:phases