diff mbox series

[bug#57602] gnu: Add texlive-latex-translations.

Message ID 20220905180844.17253-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#57602] gnu: Add texlive-latex-translations. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Sept. 5, 2022, 6:08 p.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/tex.scm (texlive-latex-translations): New variable.
---
 gnu/packages/tex.scm | 23 +++++++++++++++++++++++
 1 file changed, 23 insertions(+)


base-commit: 31b4eea5c0d361dfbca119c27cbc1e8c6f65782a

Comments

Christopher Baines Sept. 10, 2022, 10:47 a.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/tex.scm (texlive-latex-translations): New variable.
> ---
>  gnu/packages/tex.scm | 23 +++++++++++++++++++++++
>  1 file changed, 23 insertions(+)

Thanks, pushed to master as fe42befd64df016d755f56107a407f5e4b5c3814.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 56308c4cf9..81b3d50414 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10664,6 +10664,29 @@  (define-public texlive-kastrup
 LaTeX and plain TeX.")
     (license (license:fsf-free "file:/binhex.dtx"))))
 
+(define-public texlive-latex-translations
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-translations"
+              (list "doc/latex/translations/"
+                    "tex/latex/translations/")
+              (base32 "0vl7ckpbkjvz3a5snzppb96ncwgmhpwb2p6cg30grfyn421kap3v")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/translations")
+    (synopsis "Internationalisation of LaTeX2e packages")
+    (description
+     ;; Polish not mentioned on CTAN, but there is a
+     ;; translations-basic-dictionary-polish.trsl file.
+     "This package (once part of the @code{exsheets} package), provides a
+framework for providing multilingual features to a LaTeX package.  The package
+has its own basic dictionaries for English, Brazilian, Catalan, Dutch, French,
+German, Polish and Spanish.  It aims to use translation material for English,
+Dutch, French, German, Italian, Spanish, Catalan, Turkish, Croatian, Hungarian,
+Danish and Portuguese from babel or polyglossia if either is in use in the
+document.")
+    (license license:lppl1.3c+)))
+
 (define-public texlive-translator
   (package
     (inherit (simple-texlive-package