diff mbox series

[bug#57595] gnu: Add texlive-latex-marginfix.

Message ID 20220905114732.24849-1-wz@freeshell.de
State Accepted
Headers show
Series [bug#57595] gnu: Add texlive-latex-marginfix. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Wiktor Żelazny Sept. 5, 2022, 11:47 a.m. UTC
From: Wiktor Żelazny <wzelazny@vurv.cz>

* gnu/packages/tex.scm (texlive-latex-marginfix): New variable.
---
 gnu/packages/tex.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: 31b4eea5c0d361dfbca119c27cbc1e8c6f65782a

Comments

Christopher Baines Sept. 10, 2022, 10:48 a.m. UTC | #1
Wiktor Żelazny <wz@freeshell.de> writes:

> From: Wiktor Żelazny <wzelazny@vurv.cz>
>
> * gnu/packages/tex.scm (texlive-latex-marginfix): New variable.
> ---
>  gnu/packages/tex.scm | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)

Thanks Wiktor, I've pushed this to master as
fe42befd64df016d755f56107a407f5e4b5c3814.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 56308c4cf9..cad4d2c7dd 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5533,6 +5533,25 @@  (define-public texlive-makecmds
 @code{\\provideenvironment} for environments.")
     (license license:lppl1.3c+)))
 
+(define-public texlive-latex-marginfix
+  (package
+    (inherit (simple-texlive-package
+              "texlive-latex-marginfix"
+              (list "doc/latex/marginfix/"
+                    "tex/latex/marginfix/")
+              (base32 "1qinf42mjry8bi5h3kgbi6hcymnk8fw0w43527wm95nc365dq0mf")
+              #:trivial? #t))
+    (build-system texlive-build-system)
+    (home-page "https://ctan.org/pkg/marginfix")
+    (synopsis "Patch \\marginpar to avoid overfull margins")
+    (description
+     "Authors using LaTeX to typeset books with significant margin material
+often run into the problem of long notes running off the bottom of the page.
+This package implements a solution to make marginpars ``just work'' by keeping
+a list of floating inserts and arranging them intelligently in the output
+routine.")
+    (license license:lppl)))
+
 (define-public texlive-metalogo
   (package
     (inherit (simple-texlive-package